summaryrefslogtreecommitdiff
path: root/dev-util/rocm-smi/files/rocm-smi-5.7.1-no-strip.patch
diff options
context:
space:
mode:
Diffstat (limited to 'dev-util/rocm-smi/files/rocm-smi-5.7.1-no-strip.patch')
-rw-r--r--dev-util/rocm-smi/files/rocm-smi-5.7.1-no-strip.patch36
1 files changed, 36 insertions, 0 deletions
diff --git a/dev-util/rocm-smi/files/rocm-smi-5.7.1-no-strip.patch b/dev-util/rocm-smi/files/rocm-smi-5.7.1-no-strip.patch
new file mode 100644
index 000000000000..07796295e71e
--- /dev/null
+++ b/dev-util/rocm-smi/files/rocm-smi-5.7.1-no-strip.patch
@@ -0,0 +1,36 @@
+--- a/oam/CMakeLists.txt
++++ b/oam/CMakeLists.txt
+@@ -82,15 +82,6 @@ set_property(TARGET ${OAM_TARGET} PROPERTY
+ set_property(TARGET ${OAM_TARGET} PROPERTY
+ VERSION "${SO_VERSION_STRING}")
+
+-## If the library is a release, strip the target library
+-if ("${CMAKE_BUILD_TYPE}" STREQUAL Release)
+- if(${BUILD_SHARED_LIBS}) #striping only for .so
+- add_custom_command(
+- TARGET ${OAM_TARGET}
+- POST_BUILD COMMAND ${CMAKE_STRIP} lib${OAM_TARGET}.so)
+- endif()
+-endif ()
+-
+ # use the target_include_directories() command to specify the include directories for the target
+ target_include_directories(${OAM_TARGET}
+ PUBLIC
+--- a/rocm_smi/CMakeLists.txt
++++ b/rocm_smi/CMakeLists.txt
+@@ -103,15 +103,6 @@ set_property(TARGET ${ROCM_SMI_TARGET} PROPERTY
+ set_property(TARGET ${ROCM_SMI_TARGET} PROPERTY
+ VERSION "${SO_VERSION_STRING}")
+
+-## If the library is a release, strip the target library
+-if ("${CMAKE_BUILD_TYPE}" STREQUAL Release)
+- if(${BUILD_SHARED_LIBS}) #stripping only for .so
+- add_custom_command(
+- TARGET ${ROCM_SMI_TARGET}
+- POST_BUILD COMMAND ${CMAKE_STRIP} lib${ROCM_SMI_TARGET}.so.${SO_VERSION_STRING})
+- endif()
+-endif ()
+-
+ #file reorganization changes
+ #rocm_smi.py moved to libexec/rocm_smi. so creating rocm-smi symlink
+ file(MAKE_DIRECTORY ${CMAKE_CURRENT_BINARY_DIR}/bin)