summaryrefslogtreecommitdiff
path: root/dev-util/premake/premake-4.4_beta5.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-util/premake/premake-4.4_beta5.ebuild')
-rw-r--r--dev-util/premake/premake-4.4_beta5.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/dev-util/premake/premake-4.4_beta5.ebuild b/dev-util/premake/premake-4.4_beta5.ebuild
new file mode 100644
index 000000000000..68325bfb5d3b
--- /dev/null
+++ b/dev-util/premake/premake-4.4_beta5.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+MY_P=${P/_/-}
+
+inherit versionator
+
+DESCRIPTION="A makefile generation tool"
+HOMEPAGE="https://premake.github.io/"
+SRC_URI="mirror://sourceforge/premake/${MY_P}-src.zip"
+
+LICENSE="BSD"
+SLOT=$(get_major_version)
+KEYWORDS="~amd64 ~ppc ~x86"
+
+DEPEND="app-arch/unzip"
+
+S="${WORKDIR}/${MY_P}"
+
+src_prepare() {
+ default
+
+ sed 's/$(ARCH) //g' -i build/gmake.unix/Premake4.make || die
+}
+
+src_compile() {
+ emake -C build/gmake.unix/
+}
+
+src_install() {
+ dobin bin/release/premake${SLOT}
+
+ einstalldocs
+}