summaryrefslogtreecommitdiff
path: root/dev-util/premake/premake-3.7.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-util/premake/premake-3.7.ebuild')
-rw-r--r--dev-util/premake/premake-3.7.ebuild24
1 files changed, 24 insertions, 0 deletions
diff --git a/dev-util/premake/premake-3.7.ebuild b/dev-util/premake/premake-3.7.ebuild
new file mode 100644
index 000000000000..91026f3efad0
--- /dev/null
+++ b/dev-util/premake/premake-3.7.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+inherit versionator
+
+DESCRIPTION="A makefile generation tool"
+HOMEPAGE="http://industriousone.com/premake"
+SRC_URI="mirror://sourceforge/${PN}/${PN}-src-${PV}.zip"
+
+LICENSE="GPL-2"
+SLOT=$(get_major_version)
+KEYWORDS="amd64 x86"
+IUSE=""
+
+DEPEND="app-arch/unzip"
+RDEPEND=""
+
+S=${WORKDIR}/${P/p/P}
+
+src_install() {
+ dobin bin/${PN}
+}