summaryrefslogtreecommitdiff
path: root/dev-util/ply
diff options
context:
space:
mode:
Diffstat (limited to 'dev-util/ply')
-rw-r--r--dev-util/ply/Manifest2
-rw-r--r--dev-util/ply/ply-2.3.0.ebuild16
2 files changed, 15 insertions, 3 deletions
diff --git a/dev-util/ply/Manifest b/dev-util/ply/Manifest
index 2c204acaba9f..b9e7d6049421 100644
--- a/dev-util/ply/Manifest
+++ b/dev-util/ply/Manifest
@@ -1,4 +1,4 @@
DIST ply-2.3.0-arm-build-fix.patch 1433 BLAKE2B 305bb06ce1e5516dc3868cd276edc94d89cb7c20866094c6947092048af2c090a29bae52dc82956cbf7f36e42e15d873c553948dade17f4b1f9d490bb8191ed9 SHA512 e7572e5e777e13b483e9123fc5c62d63f3f1a2c753d7dedce8de8d78a4c5baa9c10b45b0e31ba16a92b0e2af11e206662cfe815643f0a8145f8d79e388d536b9
DIST ply-2.3.0.tar.gz 79753 BLAKE2B 7c2f71a6078ff65ce92b3959c3dac31d44fcf3b99fc0b2d0390152fcdfcb5f1620090b26a47f6579aaa7b7644700f2865e2693707e8746cdd78c77ce66e9ead1 SHA512 ee8acd31bef7b2ac318ef64f7775aae2b288bae15a7b7b5b28c2ce5728e8ece7833ce192bd10488dd54228685d3dc9053679a033960ed75fd91a10bb0fa6d912
-EBUILD ply-2.3.0.ebuild 1162 BLAKE2B 8b04bba2ece7224558d9f64615e488cfa22afdcbe3bd827bce1427de079afe9a4d30306768ebc1c8bd36fd148379d9e10d42b7ab40245426ee88086066a08826 SHA512 3895076f4408568e067e1cbc4f3b24c9911c34c8069f89235bacb7a0b4f785c621a02db7272af6320402f51a2b19c0139b34fbd0865362b0606a410ba43e2dbf
+EBUILD ply-2.3.0.ebuild 1397 BLAKE2B 3c20b073897f5ee43d6d37190e4d57af73c7dc51fd0353405fd47e9dd970c4b4fca1700d6a216a7736b809eda24345186af2d61d0d85ab4c51eb45f9dac991bd SHA512 f48d4b237549762d267dfba444abbe36fad1345717a2c46acb4c84da8e472b2443d76c48018ca4819dcd15ba1b69a6b3a6770b35fff6ac20b047079be332d4ec
MISC metadata.xml 303 BLAKE2B c5e15a91a2b9f1af303fbb016c08e777c643de84190c2558db22c57545b8fb16e4b7ea40748591db040fd3919a8d62e7ae55739725ada15b5b7b49674d512d62 SHA512 de63bee2c693af627b367fa9d9bff27329004d3071d590137d262e7f096d20f86d16753f6b8833d12684340dfc0c0722ce551bb4eae9abe6de552f05c571396c
diff --git a/dev-util/ply/ply-2.3.0.ebuild b/dev-util/ply/ply-2.3.0.ebuild
index d6512d640f1a..ba9de28027fe 100644
--- a/dev-util/ply/ply-2.3.0.ebuild
+++ b/dev-util/ply/ply-2.3.0.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-inherit autotools linux-info
+inherit autotools flag-o-matic linux-info
DESCRIPTION="Dynamic instrumentation of the Linux kernel with BPF and kprobes"
HOMEPAGE="https://github.com/iovisor/ply"
@@ -34,6 +34,18 @@ src_prepare() {
eautoreconf
}
+src_configure() {
+ # -Werror=strict-aliasing
+ # https://bugs.gentoo.org/858458
+ # https://github.com/iovisor/ply/issues/92
+ #
+ # Do not trust it with LTO either.
+ append-flags -fno-strict-aliasing
+ filter-lto
+
+ default
+}
+
src_install() {
default
rm -f "${ED}/usr/share/doc/${P}/COPYING"