summaryrefslogtreecommitdiff
path: root/dev-util/ply/ply-2.3.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-util/ply/ply-2.3.0.ebuild')
-rw-r--r--dev-util/ply/ply-2.3.0.ebuild16
1 files changed, 14 insertions, 2 deletions
diff --git a/dev-util/ply/ply-2.3.0.ebuild b/dev-util/ply/ply-2.3.0.ebuild
index d6512d640f1a..ba9de28027fe 100644
--- a/dev-util/ply/ply-2.3.0.ebuild
+++ b/dev-util/ply/ply-2.3.0.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-inherit autotools linux-info
+inherit autotools flag-o-matic linux-info
DESCRIPTION="Dynamic instrumentation of the Linux kernel with BPF and kprobes"
HOMEPAGE="https://github.com/iovisor/ply"
@@ -34,6 +34,18 @@ src_prepare() {
eautoreconf
}
+src_configure() {
+ # -Werror=strict-aliasing
+ # https://bugs.gentoo.org/858458
+ # https://github.com/iovisor/ply/issues/92
+ #
+ # Do not trust it with LTO either.
+ append-flags -fno-strict-aliasing
+ filter-lto
+
+ default
+}
+
src_install() {
default
rm -f "${ED}/usr/share/doc/${P}/COPYING"