summaryrefslogtreecommitdiff
path: root/dev-util/pkgdiff/pkgdiff-1.7.2.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-util/pkgdiff/pkgdiff-1.7.2.ebuild')
-rw-r--r--dev-util/pkgdiff/pkgdiff-1.7.2.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/dev-util/pkgdiff/pkgdiff-1.7.2.ebuild b/dev-util/pkgdiff/pkgdiff-1.7.2.ebuild
new file mode 100644
index 000000000000..10a3971dd704
--- /dev/null
+++ b/dev-util/pkgdiff/pkgdiff-1.7.2.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="Package Changes Analyzer (pkgdiff)"
+HOMEPAGE="https://github.com/lvc/pkgdiff"
+SRC_URI="https://github.com/lvc/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64"
+
+DEPEND=">=dev-lang/perl-5"
+RDEPEND="${DEPEND}
+ sys-apps/diffutils
+ app-text/wdiff
+ sys-apps/gawk
+ sys-devel/binutils
+"
+
+src_compile() {
+ :
+}
+
+PREFIX="/usr"
+
+src_install() {
+ mkdir -p "${D}${PREFIX}"
+ perl Makefile.pl -install --destdir "${D}" || die "install failed"
+}