summaryrefslogtreecommitdiff
path: root/dev-util/pkgcheck/pkgcheck-9999.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-util/pkgcheck/pkgcheck-9999.ebuild')
-rw-r--r--dev-util/pkgcheck/pkgcheck-9999.ebuild15
1 files changed, 5 insertions, 10 deletions
diff --git a/dev-util/pkgcheck/pkgcheck-9999.ebuild b/dev-util/pkgcheck/pkgcheck-9999.ebuild
index 6a4fce0ea524..2b1a33742b3b 100644
--- a/dev-util/pkgcheck/pkgcheck-9999.ebuild
+++ b/dev-util/pkgcheck/pkgcheck-9999.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
-PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} )
+EAPI=6
+PYTHON_COMPAT=( python3_6 )
DISTUTILS_IN_SOURCE_BUILD=1
inherit distutils-r1
@@ -26,19 +26,14 @@ if [[ ${PV} == *9999 ]]; then
=sys-apps/pkgcore-9999[${PYTHON_USEDEP}]"
else
RDEPEND="
- >=dev-python/snakeoil-0.7.2[${PYTHON_USEDEP}]
- >=sys-apps/pkgcore-0.9.5[${PYTHON_USEDEP}]"
+ >=dev-python/snakeoil-0.8.0[${PYTHON_USEDEP}]
+ >=sys-apps/pkgcore-0.10.0[${PYTHON_USEDEP}]"
fi
RDEPEND+=" dev-python/lxml[${PYTHON_USEDEP}]"
DEPEND="${RDEPEND}
dev-python/setuptools[${PYTHON_USEDEP}]"
[[ ${PV} == *9999 ]] && DEPEND+=" dev-python/sphinx[${PYTHON_USEDEP}]"
-pkg_setup() {
- # disable snakeoil 2to3 caching...
- unset PY2TO3_CACHEDIR
-}
-
python_compile_all() {
esetup.py build_man
}