summaryrefslogtreecommitdiff
path: root/dev-util/pkgcheck/pkgcheck-9999.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-util/pkgcheck/pkgcheck-9999.ebuild')
-rw-r--r--dev-util/pkgcheck/pkgcheck-9999.ebuild17
1 files changed, 10 insertions, 7 deletions
diff --git a/dev-util/pkgcheck/pkgcheck-9999.ebuild b/dev-util/pkgcheck/pkgcheck-9999.ebuild
index 2b1a33742b3b..898fbc5e514f 100644
--- a/dev-util/pkgcheck/pkgcheck-9999.ebuild
+++ b/dev-util/pkgcheck/pkgcheck-9999.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
-PYTHON_COMPAT=( python3_6 )
+PYTHON_COMPAT=( python3_{6,7} )
DISTUTILS_IN_SOURCE_BUILD=1
inherit distutils-r1
@@ -19,11 +19,12 @@ HOMEPAGE="https://github.com/pkgcore/pkgcheck"
LICENSE="|| ( BSD GPL-2 )"
SLOT="0"
+IUSE="doc"
if [[ ${PV} == *9999 ]]; then
RDEPEND="
- =dev-python/snakeoil-9999[${PYTHON_USEDEP}]
- =sys-apps/pkgcore-9999[${PYTHON_USEDEP}]"
+ ~dev-python/snakeoil-9999[${PYTHON_USEDEP}]
+ ~sys-apps/pkgcore-9999[${PYTHON_USEDEP}]"
else
RDEPEND="
>=dev-python/snakeoil-0.8.0[${PYTHON_USEDEP}]
@@ -31,11 +32,11 @@ else
fi
RDEPEND+=" dev-python/lxml[${PYTHON_USEDEP}]"
DEPEND="${RDEPEND}
+ doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
dev-python/setuptools[${PYTHON_USEDEP}]"
-[[ ${PV} == *9999 ]] && DEPEND+=" dev-python/sphinx[${PYTHON_USEDEP}]"
python_compile_all() {
- esetup.py build_man
+ use doc && esetup.py build_man
}
python_test() {
@@ -44,7 +45,9 @@ python_test() {
python_install_all() {
local DOCS=( AUTHORS NEWS.rst )
- distutils-r1_python_install install_man
+ esetup.py install_docs \
+ --docdir="${ED%/}/usr/share/doc/${PF}" \
+ --mandir="${ED%/}/usr/share/man"
distutils-r1_python_install_all
}