summaryrefslogtreecommitdiff
path: root/dev-util/patdiff/patdiff-0.15.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-util/patdiff/patdiff-0.15.0.ebuild')
-rw-r--r--dev-util/patdiff/patdiff-0.15.0.ebuild22
1 files changed, 22 insertions, 0 deletions
diff --git a/dev-util/patdiff/patdiff-0.15.0.ebuild b/dev-util/patdiff/patdiff-0.15.0.ebuild
new file mode 100644
index 000000000000..8a8584db976a
--- /dev/null
+++ b/dev-util/patdiff/patdiff-0.15.0.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit dune
+
+DESCRIPTION="Colored patience diffs with word-level refinement"
+HOMEPAGE="https://github.com/janestreet/patdiff"
+SRC_URI="https://github.com/janestreet/patdiff/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0/$(ver_cut 1-2)"
+KEYWORDS="~amd64 ~riscv"
+IUSE="+ocamlopt"
+
+RDEPEND="
+ dev-ml/core_unix:${SLOT}
+ dev-ml/patience_diff:${SLOT}
+ dev-ml/pcre-ocaml:=
+"
+DEPEND="${RDEPEND}"