summaryrefslogtreecommitdiff
path: root/dev-util/packer/packer-1.9.5.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-util/packer/packer-1.9.5.ebuild')
-rw-r--r--dev-util/packer/packer-1.9.5.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/dev-util/packer/packer-1.9.5.ebuild b/dev-util/packer/packer-1.9.5.ebuild
new file mode 100644
index 000000000000..da2364a5b847
--- /dev/null
+++ b/dev-util/packer/packer-1.9.5.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit go-module
+
+DESCRIPTION="A tool to create identical machine images for multiple platforms"
+HOMEPAGE="https://www.packer.io"
+SRC_URI="https://github.com/hashicorp/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz
+ https://gentoo.neutroniak.com/${P}-deps.tar.xz"
+
+LICENSE="Apache-2.0 BSD-2 BSD-4 MIT MPL-2.0 unicode"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~riscv"
+
+DOCS=( {README,CHANGELOG}.md )
+
+RESTRICT+=" test"
+
+src_compile() {
+ ego build \
+ -mod=readonly \
+ -ldflags "${go_ldflags}" \
+ -work -o "bin/${PN}" ./ || die
+}
+
+src_install() {
+ dobin bin/packer
+
+ einstalldocs
+
+ insinto /usr/share/zsh/site-functions
+ doins contrib/zsh-completion/_packer
+}