summaryrefslogtreecommitdiff
path: root/dev-util/packer/packer-1.3.3.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-util/packer/packer-1.3.3.ebuild')
-rw-r--r--dev-util/packer/packer-1.3.3.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/dev-util/packer/packer-1.3.3.ebuild b/dev-util/packer/packer-1.3.3.ebuild
new file mode 100644
index 000000000000..8cae3f47d007
--- /dev/null
+++ b/dev-util/packer/packer-1.3.3.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit golang-vcs-snapshot
+
+DESCRIPTION="A tool to create identical machine images for multiple platforms"
+HOMEPAGE="https://www.packer.io"
+
+EGO_PN="github.com/hashicorp/packer"
+SRC_URI="https://github.com/hashicorp/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MPL-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+DEPEND=">=dev-lang/go-1.11.0"
+
+DOCS="README.md CHANGELOG.md"
+
+src_compile() {
+ cd "src/${EGO_PN}" || die
+ GOPATH="${S}" GOCACHE="${T}/go-cache" go build \
+ -v -work -o "${S}/${PN}" ./ || die
+}
+
+src_install() {
+ dobin packer
+
+ pushd "src/${EGO_PN}" || die
+ einstalldocs
+ insinto /usr/share/zsh/site-functions
+ doins contrib/zsh-completion/_packer
+ popd || die
+}