summaryrefslogtreecommitdiff
path: root/dev-util/open-vcdiff/open-vcdiff-0.8.4-r2.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-util/open-vcdiff/open-vcdiff-0.8.4-r2.ebuild')
-rw-r--r--dev-util/open-vcdiff/open-vcdiff-0.8.4-r2.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/dev-util/open-vcdiff/open-vcdiff-0.8.4-r2.ebuild b/dev-util/open-vcdiff/open-vcdiff-0.8.4-r2.ebuild
new file mode 100644
index 000000000000..2458630842fc
--- /dev/null
+++ b/dev-util/open-vcdiff/open-vcdiff-0.8.4-r2.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="An encoder/decoder for the VCDIFF (RFC3284) format"
+HOMEPAGE="https://github.com/google/open-vcdiff"
+SRC_URI="https://dev.gentoo.org/~floppym/dist/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0/0"
+KEYWORDS="~amd64 ~x86"
+
+PATCHES=( "${FILESDIR}"/${P}-gcc6.patch )
+
+src_prepare() {
+ sed -i -e "s|^docdir =.*|docdir = \"${EPREFIX}/usr/share/doc/${PF}\"|g" \
+ Makefile.in || die
+ default
+}
+
+src_install() {
+ default
+ find "${D}" -name '*.la' -delete || die
+}