summaryrefslogtreecommitdiff
path: root/dev-util/mingw64-toolchain/mingw64-toolchain-11.0.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-util/mingw64-toolchain/mingw64-toolchain-11.0.0.ebuild')
-rw-r--r--dev-util/mingw64-toolchain/mingw64-toolchain-11.0.0.ebuild7
1 files changed, 7 insertions, 0 deletions
diff --git a/dev-util/mingw64-toolchain/mingw64-toolchain-11.0.0.ebuild b/dev-util/mingw64-toolchain/mingw64-toolchain-11.0.0.ebuild
index d4fe6b516d10..803cd398d9be 100644
--- a/dev-util/mingw64-toolchain/mingw64-toolchain-11.0.0.ebuild
+++ b/dev-util/mingw64-toolchain/mingw64-toolchain-11.0.0.ebuild
@@ -201,6 +201,13 @@ src_compile() {
CHOST=${CTARGET}
filter-flags '-fuse-ld=*'
filter-flags '-mfunction-return=thunk*' #878849
+
+ # -mavx with mingw-gcc has a history of obscure issues and
+ # disabling is seen as safer, e.g. `WINEARCH=win32 winecfg`
+ # crashes with -march=skylake >=wine-8.10, similar issues with
+ # znver4: https://gcc.gnu.org/bugzilla/show_bug.cgi?id=110273
+ append-flags -mno-avx
+
strip-unsupported-flags
mwt-build "${@:2}"
)