summaryrefslogtreecommitdiff
path: root/dev-util/mingw64-runtime/mingw64-runtime-11.0.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-util/mingw64-runtime/mingw64-runtime-11.0.0.ebuild')
-rw-r--r--dev-util/mingw64-runtime/mingw64-runtime-11.0.0.ebuild7
1 files changed, 7 insertions, 0 deletions
diff --git a/dev-util/mingw64-runtime/mingw64-runtime-11.0.0.ebuild b/dev-util/mingw64-runtime/mingw64-runtime-11.0.0.ebuild
index e9b21a93f78c..5e0b60934d20 100644
--- a/dev-util/mingw64-runtime/mingw64-runtime-11.0.0.ebuild
+++ b/dev-util/mingw64-runtime/mingw64-runtime-11.0.0.ebuild
@@ -65,6 +65,13 @@ src_configure() {
filter-flags '-mfunction-return=thunk*' #878849
fi
local CHOST=${CTARGET}
+
+ # -mavx with mingw-gcc has a history of obscure issues and
+ # disabling is seen as safer, e.g. `WINEARCH=win32 winecfg`
+ # crashes with -march=skylake >=wine-8.10, similar issues with
+ # znver4: https://gcc.gnu.org/bugzilla/show_bug.cgi?id=110273
+ tc-is-gcc && append-flags -mno-avx
+
strip-unsupported-flags
# Normally mingw64 does not use dynamic linker, but at configure time it