summaryrefslogtreecommitdiff
path: root/dev-util/meson/files/1.2.2/0005-tests-fix-test-case-to-not-import-distutils-on-pytho.patch
diff options
context:
space:
mode:
Diffstat (limited to 'dev-util/meson/files/1.2.2/0005-tests-fix-test-case-to-not-import-distutils-on-pytho.patch')
-rw-r--r--dev-util/meson/files/1.2.2/0005-tests-fix-test-case-to-not-import-distutils-on-pytho.patch31
1 files changed, 31 insertions, 0 deletions
diff --git a/dev-util/meson/files/1.2.2/0005-tests-fix-test-case-to-not-import-distutils-on-pytho.patch b/dev-util/meson/files/1.2.2/0005-tests-fix-test-case-to-not-import-distutils-on-pytho.patch
new file mode 100644
index 000000000000..078e9035e228
--- /dev/null
+++ b/dev-util/meson/files/1.2.2/0005-tests-fix-test-case-to-not-import-distutils-on-pytho.patch
@@ -0,0 +1,31 @@
+From ae44d9a379faca6274db819be44ffca3e0159f56 Mon Sep 17 00:00:00 2001
+From: Eli Schwartz <eschwartz93@gmail.com>
+Date: Mon, 2 Oct 2023 23:51:57 -0400
+Subject: [PATCH 5/7] tests: fix test case to not import distutils on python
+ 3.12
+
+Testing the correctness of the `modules: ` kwarg can be done with other
+guaranteed stdlib modules that are even more guaranteed since they
+didn't get deprecated for removal.
+
+(cherry picked from commit ecf261330c498783760cbde00b613b7469f8d3c0)
+---
+ test cases/python/5 modules kwarg/meson.build | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/test cases/python/5 modules kwarg/meson.build b/test cases/python/5 modules kwarg/meson.build
+index 9751adaab..41a9a4fae 100644
+--- a/test cases/python/5 modules kwarg/meson.build
++++ b/test cases/python/5 modules kwarg/meson.build
+@@ -1,7 +1,7 @@
+ project('python kwarg')
+
+ py = import('python')
+-prog_python = py.find_installation('python3', modules : ['distutils'])
++prog_python = py.find_installation('python3', modules : ['os', 'sys', 're'])
+ assert(prog_python.found() == true, 'python not found when should be')
+ prog_python = py.find_installation('python3', modules : ['thisbetternotexistmod'], required : false)
+ assert(prog_python.found() == false, 'python not found but reported as found')
+--
+2.42.0
+