summaryrefslogtreecommitdiff
path: root/dev-util/makeheaders/makeheaders-0_p4.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-util/makeheaders/makeheaders-0_p4.ebuild')
-rw-r--r--dev-util/makeheaders/makeheaders-0_p4.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/dev-util/makeheaders/makeheaders-0_p4.ebuild b/dev-util/makeheaders/makeheaders-0_p4.ebuild
new file mode 100644
index 000000000000..0d4b0aa383c8
--- /dev/null
+++ b/dev-util/makeheaders/makeheaders-0_p4.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit toolchain-funcs
+
+DESCRIPTION="simple utility that will automatically generate header files"
+HOMEPAGE="http://www.hwaci.com/sw/mkhdr/"
+SRC_URI="
+ http://www.hwaci.com/sw/mkhdr/makeheaders.c -> ${P}.c
+ http://www.hwaci.com/sw/mkhdr/makeheaders.html -> ${P}.html"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="amd64 ~ppc ~sparc x86"
+IUSE=""
+
+S=${WORKDIR}
+
+src_compile() {
+ $(tc-getCC) ${CFLAGS} ${CPPFLAGS} ${LDFLAGS} -o ${PN} "${DISTDIR}"/${P}.c || die
+}
+
+src_install() {
+ dobin ${PN}
+
+ local HTML_DOCS=( "${DISTDIR}"/${P}.html )
+ einstalldocs
+}