summaryrefslogtreecommitdiff
path: root/dev-util/lldb/lldb-6.0.9999.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-util/lldb/lldb-6.0.9999.ebuild')
-rw-r--r--dev-util/lldb/lldb-6.0.9999.ebuild15
1 files changed, 6 insertions, 9 deletions
diff --git a/dev-util/lldb/lldb-6.0.9999.ebuild b/dev-util/lldb/lldb-6.0.9999.ebuild
index 002f1571b638..cf7c78750f2b 100644
--- a/dev-util/lldb/lldb-6.0.9999.ebuild
+++ b/dev-util/lldb/lldb-6.0.9999.ebuild
@@ -68,15 +68,10 @@ src_configure() {
-DLLDB_DISABLE_CURSES=$(usex !ncurses)
-DLLDB_DISABLE_LIBEDIT=$(usex !libedit)
-DLLDB_DISABLE_PYTHON=$(usex !python)
+ -DLLDB_USE_SYSTEM_SIX=1
-DLLVM_ENABLE_TERMINFO=$(usex ncurses)
-DLLDB_INCLUDE_TESTS=$(usex test)
- -DLLVM_BUILD_TESTS=$(usex test)
- # compilers for lit tests
- -DLLDB_TEST_C_COMPILER="$(type -P clang)"
- -DLLDB_TEST_CXX_COMPILER="$(type -P clang++)"
- # compiler for ole' python tests
- -DLLDB_TEST_COMPILER="$(type -P clang)"
# TODO: fix upstream to detect this properly
-DHAVE_LIBDL=ON
@@ -89,6 +84,11 @@ src_configure() {
-DCURSES_NEED_NCURSES=ON
)
use test && mycmakeargs+=(
+ -DLLVM_BUILD_TESTS=$(usex test)
+ # compilers for lit tests
+ -DLLDB_TEST_C_COMPILER="$(type -P clang)"
+ -DLLDB_TEST_CXX_COMPILER="$(type -P clang++)"
+
-DLLVM_MAIN_SRC_DIR="${WORKDIR}/llvm"
-DLLVM_EXTERNAL_LIT="${EPREFIX}/usr/bin/lit"
-DLLVM_LIT_ARGS="-vv"
@@ -107,9 +107,6 @@ src_install() {
# oh my...
if use python; then
- # remove bundled six module
- rm "${D}$(python_get_sitedir)/six.py" || die
-
# remove custom readline.so for now
# TODO: figure out how to deal with it
# upstream is basically building a custom readline.so with -ledit