summaryrefslogtreecommitdiff
path: root/dev-util/japi-compliance-checker/japi-compliance-checker-9999.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-util/japi-compliance-checker/japi-compliance-checker-9999.ebuild')
-rw-r--r--dev-util/japi-compliance-checker/japi-compliance-checker-9999.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/dev-util/japi-compliance-checker/japi-compliance-checker-9999.ebuild b/dev-util/japi-compliance-checker/japi-compliance-checker-9999.ebuild
new file mode 100644
index 000000000000..0c12532893d7
--- /dev/null
+++ b/dev-util/japi-compliance-checker/japi-compliance-checker-9999.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit git-r3
+
+DESCRIPTION="Java API compliance checker"
+HOMEPAGE="https://github.com/lvc/japi-compliance-checker"
+EGIT_REPO_URI="https://github.com/lvc/japi-compliance-checker.git"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS=""
+
+DEPEND=">=dev-lang/perl-5"
+RDEPEND="${DEPEND}
+ >=virtual/jdk-1.8:*
+"
+
+src_compile() {
+ :
+}
+
+PREFIX="/usr"
+
+src_install() {
+ mkdir -p "${D}${PREFIX}"
+ perl Makefile.pl -install --destdir "${D}" || die "install failed"
+}