summaryrefslogtreecommitdiff
path: root/dev-util/indent/indent-2.2.12.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-util/indent/indent-2.2.12.ebuild')
-rw-r--r--dev-util/indent/indent-2.2.12.ebuild17
1 files changed, 8 insertions, 9 deletions
diff --git a/dev-util/indent/indent-2.2.12.ebuild b/dev-util/indent/indent-2.2.12.ebuild
index 1518ed284af8..07e8341f0b32 100644
--- a/dev-util/indent/indent-2.2.12.ebuild
+++ b/dev-util/indent/indent-2.2.12.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-inherit strip-linguas
+inherit autotools strip-linguas
DESCRIPTION="Indent program source files"
HOMEPAGE="https://www.gnu.org/software/indent/"
@@ -14,17 +14,16 @@ SLOT="0"
KEYWORDS="~alpha amd64 arm ~hppa ~ia64 ~mips ppc ppc64 ~s390 sparc x86 ~amd64-linux ~x86-linux ~ppc-macos ~sparc-solaris ~x86-solaris"
IUSE="nls"
-BDEPEND="
- app-text/texi2html
- nls? ( sys-devel/gettext )
-"
-RDEPEND="
- nls? ( virtual/libintl )
-"
+BDEPEND="app-text/texi2html
+ nls? ( sys-devel/gettext )"
+DEPEND="nls? ( virtual/libintl )"
+RDEPEND="${DEPEND}"
src_prepare() {
default
+
sed -i -e '/AM_CFLAGS/s:-Werror::g' src/Makefile.{am,in} || die
+ eautoreconf
}
src_configure() {