summaryrefslogtreecommitdiff
path: root/dev-util/indent/indent-2.2.12.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-util/indent/indent-2.2.12.ebuild')
-rw-r--r--dev-util/indent/indent-2.2.12.ebuild11
1 files changed, 9 insertions, 2 deletions
diff --git a/dev-util/indent/indent-2.2.12.ebuild b/dev-util/indent/indent-2.2.12.ebuild
index a8d9e29f1f6b..6ba9d6e6fd5e 100644
--- a/dev-util/indent/indent-2.2.12.ebuild
+++ b/dev-util/indent/indent-2.2.12.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -30,7 +30,14 @@ src_prepare() {
src_configure() {
strip-linguas -i po/
- gl_cv_cc_vis_werror=no econf $(use_enable nls)
+ if use nls; then
+ gl_cv_cc_vis_werror=no \
+ econf $(use_enable nls)
+ else
+ ac_cv_func_setlocale=no \
+ gl_cv_cc_vis_werror=no \
+ econf $(use_enable nls)
+ fi
}
src_test() {