summaryrefslogtreecommitdiff
path: root/dev-util/huc/huc-0.1-r1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-util/huc/huc-0.1-r1.ebuild')
-rw-r--r--dev-util/huc/huc-0.1-r1.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/dev-util/huc/huc-0.1-r1.ebuild b/dev-util/huc/huc-0.1-r1.ebuild
new file mode 100644
index 000000000000..c2261b0ddc2d
--- /dev/null
+++ b/dev-util/huc/huc-0.1-r1.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit toolchain-funcs
+
+DESCRIPTION="HTML umlaut conversion tool"
+SRC_URI="http://www.int21.de/huc/${P}.tar.bz2"
+HOMEPAGE="http://www.int21.de/huc"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="amd64 ppc sparc x86 ~x86-linux ~ppc-macos"
+
+src_compile() {
+ $(tc-getCXX) \
+ ${LDFLAGS} ${CXXFLAGS} \
+ -o ${PN} ${PN}.cpp || die "compile failed"
+}
+
+src_install () {
+ dobin "${PN}"
+ einstalldocs
+}