summaryrefslogtreecommitdiff
path: root/dev-util/hadolint/hadolint-1.4.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-util/hadolint/hadolint-1.4.0.ebuild')
-rw-r--r--dev-util/hadolint/hadolint-1.4.0.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/dev-util/hadolint/hadolint-1.4.0.ebuild b/dev-util/hadolint/hadolint-1.4.0.ebuild
new file mode 100644
index 000000000000..2f335d90eea9
--- /dev/null
+++ b/dev-util/hadolint/hadolint-1.4.0.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+# ebuild generated by hackport 0.5.4
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="Dockerfile Linter JavaScript API"
+HOMEPAGE="https://github.com/hadolint/hadolint"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=dev-haskell/gitrev-1.3.1:=[profile?]
+ >=dev-haskell/language-docker-2.0.0:=[profile?]
+ <=dev-haskell/optparse-applicative-0.14.0.0:=[profile?]
+ >=dev-haskell/parsec-3.1:=[profile?]
+ >=dev-haskell/split-0.2:=[profile?]
+ dev-haskell/yaml:=[profile?]
+ >=dev-lang/ghc-8.0.2:=
+ >=dev-util/shellcheck-0.4.7:=[profile?]
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.24.2.0
+ test? ( dev-haskell/hspec
+ >=dev-haskell/hunit-1.2 )
+"
+
+src_prepare() {
+ default
+ sed -i -e "s/-static//" ${PN}.cabal || die
+}