summaryrefslogtreecommitdiff
path: root/dev-util/gyp/gyp-20170904022846.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-util/gyp/gyp-20170904022846.ebuild')
-rw-r--r--dev-util/gyp/gyp-20170904022846.ebuild39
1 files changed, 0 insertions, 39 deletions
diff --git a/dev-util/gyp/gyp-20170904022846.ebuild b/dev-util/gyp/gyp-20170904022846.ebuild
deleted file mode 100644
index d5f888d0b40b..000000000000
--- a/dev-util/gyp/gyp-20170904022846.ebuild
+++ /dev/null
@@ -1,39 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI="6"
-PYTHON_COMPAT=(python2_7)
-DISTUTILS_SINGLE_IMPL="1"
-
-inherit distutils-r1
-
-if [[ "${PV}" == "99999999999999" ]]; then
- inherit git-r3
-
- EGIT_REPO_URI="https://chromium.googlesource.com/external/gyp"
-fi
-
-DESCRIPTION="GYP (Generate Your Projects) meta-build system"
-HOMEPAGE="https://gyp.gsrc.io/ https://chromium.googlesource.com/external/gyp"
-if [[ "${PV}" == "99999999999999" ]]; then
- SRC_URI=""
-else
- SRC_URI="https://home.apache.org/~arfrever/distfiles/${P}.tar.xz"
-fi
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="amd64 ~ppc64 x86"
-IUSE=""
-REQUIRED_USE="${PYTHON_REQUIRED_USE}"
-
-DEPEND="${PYTHON_DEPS}
- dev-python/setuptools[${PYTHON_USEDEP}]"
-RDEPEND="${DEPEND}"
-
-src_test() {
- # More errors when DeprecationWarnings enabled.
- local -x PYTHONWARNINGS=""
-
- "${PYTHON}" gyptest.py --all --verbose
-}