summaryrefslogtreecommitdiff
path: root/dev-util/gitlab-cli/gitlab-cli-1.24.1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-util/gitlab-cli/gitlab-cli-1.24.1.ebuild')
-rw-r--r--dev-util/gitlab-cli/gitlab-cli-1.24.1.ebuild32
1 files changed, 0 insertions, 32 deletions
diff --git a/dev-util/gitlab-cli/gitlab-cli-1.24.1.ebuild b/dev-util/gitlab-cli/gitlab-cli-1.24.1.ebuild
deleted file mode 100644
index 1a5307e23852..000000000000
--- a/dev-util/gitlab-cli/gitlab-cli-1.24.1.ebuild
+++ /dev/null
@@ -1,32 +0,0 @@
-# Copyright 2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-inherit go-module
-GIT_COMMIT=e02b30c6e3ff7801f22d37ed63850211ca0c7bb6
-
-DESCRIPTION="the official gitlab command line interface"
-HOMEPAGE="https://gitlab.com/gitlab-org/cli"
-SRC_URI="https://gitlab.com/gitlab-org/cli/-/archive/v${PV}/${PN}-v${PV}.tar.bz2 -> ${P}.tar.bz2"
-SRC_URI+=" https://dev.gentoo.org/~williamh/dist/${P}-deps.tar.xz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64"
-
-# tests communicate with gitlab.com and require a personal access token
-RESTRICT="test"
-
-S="${WORKDIR}/cli-v${PV}-${GIT_COMMIT}"
-
-src_compile() {
- emake \
- GLAB_VERSION=v${PV} \
- build manpage
-}
-
-src_install() {
- dobin bin/glab
- dodoc README.md
- doman share/man/man1/*
-}