summaryrefslogtreecommitdiff
path: root/dev-util/gertty/gertty-1.6.0-r2.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-util/gertty/gertty-1.6.0-r2.ebuild')
-rw-r--r--dev-util/gertty/gertty-1.6.0-r2.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/dev-util/gertty/gertty-1.6.0-r2.ebuild b/dev-util/gertty/gertty-1.6.0-r2.ebuild
new file mode 100644
index 000000000000..bb526e970682
--- /dev/null
+++ b/dev-util/gertty/gertty-1.6.0-r2.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{9..11} )
+DISTUTILS_USE_PEP517=setuptools
+
+inherit distutils-r1
+
+DESCRIPTION="Gertty is a console-based interface to the Gerrit Code Review system"
+HOMEPAGE="https://pypi.org/project/gertty/"
+if [[ ${PV} == *9999 ]];then
+ inherit git-r3
+ EGIT_REPO_URI="https://opendev.org/ttygroup/gertty"
+ EGIT_BRANCH="master"
+else
+ inherit pypi
+ KEYWORDS="amd64 x86 ~amd64-linux ~x86-linux"
+fi
+
+LICENSE="Apache-2.0"
+SLOT="0"
+IUSE=""
+
+DEPEND=">=dev-python/pbr-0.11[${PYTHON_USEDEP}]"
+RDEPEND="
+ >=dev-python/pbr-0.11[${PYTHON_USEDEP}]
+ >=dev-python/urwid-1.2.1[${PYTHON_USEDEP}]
+ >=dev-python/sqlalchemy-1.0.4[${PYTHON_USEDEP}]
+ >=dev-python/GitPython-0.3.7[${PYTHON_USEDEP}]
+ dev-python/python-dateutil[${PYTHON_USEDEP}]
+ >=dev-python/requests-2.5.3[${PYTHON_USEDEP}]
+ <dev-python/requests-3.0.0[${PYTHON_USEDEP}]
+ >=dev-python/alembic-0.6.4[${PYTHON_USEDEP}]
+ >=dev-python/pyyaml-3.1.0[${PYTHON_USEDEP}]
+ >=dev-python/voluptuous-0.7[${PYTHON_USEDEP}]
+ >=dev-python/ply-3.4[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]"