summaryrefslogtreecommitdiff
path: root/dev-util/geany/geany-9999.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-util/geany/geany-9999.ebuild')
-rw-r--r--dev-util/geany/geany-9999.ebuild13
1 files changed, 7 insertions, 6 deletions
diff --git a/dev-util/geany/geany-9999.ebuild b/dev-util/geany/geany-9999.ebuild
index f8bb6955d661..2dde606ada78 100644
--- a/dev-util/geany/geany-9999.ebuild
+++ b/dev-util/geany/geany-9999.ebuild
@@ -6,7 +6,7 @@ EAPI=7
# eutils required for strip-linguas
inherit eutils xdg
-LANGS="ar ast be bg ca cs de el en_GB es et eu fa fi fr gl he hi hu id it ja kk ko lb lt mn nl nn pl pt pt_BR ro ru sk sl sr sv tr uk vi zh_CN ZH_TW"
+LANGS="ar ast be bg ca cs de el en_GB es et eu fa fi fr gl he hi hu id it ja kk ko ku lb lt mn nl nn pl pt pt_BR ro ru sk sl sr sv tr uk vi zh_CN ZH_TW"
NOSHORTLANGS="en_GB zh_CN zh_TW"
DESCRIPTION="GTK+ based fast and lightweight IDE"
@@ -22,19 +22,19 @@ fi
LICENSE="GPL-2+ HPND"
SLOT="0"
-IUSE="+gtk3 +vte"
+IUSE="gtk2 +vte"
+BDEPEND="virtual/pkgconfig"
RDEPEND=">=dev-libs/glib-2.32:2
- !gtk3? (
+ gtk2? (
>=x11-libs/gtk+-2.24:2
vte? ( x11-libs/vte:0 )
)
- gtk3? (
+ !gtk2? (
>=x11-libs/gtk+-3.0:3
vte? ( x11-libs/vte:2.91 )
)"
DEPEND="${RDEPEND}
- virtual/pkgconfig
dev-util/intltool
sys-devel/gettext"
@@ -58,7 +58,8 @@ src_configure() {
local myeconfargs=(
--disable-html-docs
--disable-pdf-docs
- $(use_enable gtk3)
+ --disable-static
+ $(use_enable gtk2)
$(use_enable vte)
)
econf "${myeconfargs[@]}"