summaryrefslogtreecommitdiff
path: root/dev-util/geany-plugins
diff options
context:
space:
mode:
Diffstat (limited to 'dev-util/geany-plugins')
-rw-r--r--dev-util/geany-plugins/Manifest7
-rw-r--r--dev-util/geany-plugins/geany-plugins-1.30.ebuild144
-rw-r--r--dev-util/geany-plugins/geany-plugins-1.32.ebuild136
-rw-r--r--dev-util/geany-plugins/geany-plugins-1.33.ebuild136
-rw-r--r--dev-util/geany-plugins/metadata.xml29
5 files changed, 452 insertions, 0 deletions
diff --git a/dev-util/geany-plugins/Manifest b/dev-util/geany-plugins/Manifest
new file mode 100644
index 000000000000..c1be159048a9
--- /dev/null
+++ b/dev-util/geany-plugins/Manifest
@@ -0,0 +1,7 @@
+DIST geany-plugins-1.30.tar.gz 4469990 BLAKE2B 3cb8434765667814dc95227a82bdf204b2f918c951de8d5d9b56549c3fc343e1fe1c3e225d9f907da6b3227440dbdad09d0318d2738c213640a4629e9f7b42fe SHA512 11dc44215aaa369831c249ef84b5dd0ee7eecdfbbf4707fc6165d78201e9e755447463c171ac6c8b2bc70df28a97b23762073ab9b31f7c33285d4728089da807
+DIST geany-plugins-1.32.tar.gz 4655759 BLAKE2B afef1fd304b36daf4da5bd2a753c3de2c3c94d4274716fe726afc4164d98645f3f2436b306b894bb4245d86ee0782058b0181655d42764421b2d24c3e9e4c79d SHA512 0284aa28820361f419a4ca000a8781bc044e112732ea6be7e511841c18d075eceef4abcabc1153ba9ff8229e529d3e44f6aacdc668927323f2d78bb2f8897a06
+DIST geany-plugins-1.33.tar.gz 4671123 BLAKE2B 33471215480597b34e2733b7dc292e94ff12985b645fda76b2e25492573bb866766a3ea5a4598c4f643e9528f8062ffb9bf6ccabbb9be04aecbf23650d9c776d SHA512 d046eb0b7bd3c704b62c84b05564b973203ddabf6c09b94bf3008955735d672077bff1a7cda27d4eba97824231483f3e64b3b0f0234a97a1a2727d535fb28718
+EBUILD geany-plugins-1.30.ebuild 3438 BLAKE2B a0cf586e95195375680bbde21c7de798fabd3ad944c9a7934ace91285a267436938b8bf158af9a6da5d55caa3b5c258218c0f5f3c44170a0c7384bc447cec0be SHA512 ab7193e7c89b6824c33d489e8bf0b6098b814c9bff52987af9c4ca5eb059902102f94e659b90e4ba1748f9242d7fbb3a3564bd88d0826c36f4b4a3807083eb99
+EBUILD geany-plugins-1.32.ebuild 3182 BLAKE2B 5003867dc35ec00ff63552dbfc57680c0014a8af897da13ab286ed57fba913968c54fb27a2f9758744db1f3d01ebba4118d84dc325b3dc43668d4b00c85d7da1 SHA512 2779d14f320a8dfbbdec5ab9862a5fc6eb2230d09774c018ccb6bbc248b0291ebde97de7b03bff998dd41f1b2d83717531948865c7c2936a500a5a2f18c1957f
+EBUILD geany-plugins-1.33.ebuild 3166 BLAKE2B 3e6beb940b81bd921424b6d1310c2fe402675a86815c6743483d7d9b5c05b4f4cdd1818bf92086430a03bc44b3a5c4bdaf58fb7e71af5da286dcfe2d71ee11a2 SHA512 7d3ac36a212e1deeeff6256aaf6593a65c0ade96e6da40fafe28a3672d46c4b3960c9c5b68c026acfe8c1bd8bed930a5aab9707168f3e7c4fbfdc9dbcb405d93
+MISC metadata.xml 1533 BLAKE2B 33a794171fd9b6a50ea6669c4bc782f40144d7efcf3145c742f4b427c1a2389d9370085ba2661498800324c17b3bfd5608b70c7e1f24892134e338108ae08354 SHA512 7c469c01a2afc24631d1260ca010c59031d61c63c903ce13ccc5147d960f0299c5cad02f4a839df8bef1f5566a49ef443bfdd0b40eea0a4401c8fa6625f532da
diff --git a/dev-util/geany-plugins/geany-plugins-1.30.ebuild b/dev-util/geany-plugins/geany-plugins-1.30.ebuild
new file mode 100644
index 000000000000..55544248d9e4
--- /dev/null
+++ b/dev-util/geany-plugins/geany-plugins-1.30.ebuild
@@ -0,0 +1,144 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python2_7 )
+
+inherit eutils python-single-r1 vala
+
+DESCRIPTION="A collection of different plugins for Geany"
+HOMEPAGE="https://plugins.geany.org"
+SRC_URI="https://plugins.geany.org/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="alpha amd64 arm ia64 ppc ppc64 sparc x86"
+
+IUSE="gtk3 +autoclose +automark +commander ctags debugger +defineformat enchant git gpg gtkspell lua multiterm nls +overview python scope soup"
+REQUIRED_USE="
+ gtk3? ( !debugger !multiterm !python !scope )
+ python? ( ${PYTHON_REQUIRED_USE} )
+"
+
+GTK_COMMON_DEPEND="
+ gtk3? ( x11-libs/gtk+:3 )
+ !gtk3? ( x11-libs/gtk+:2 )
+"
+COMMON_DEPEND="
+ >=dev-util/geany-1.26[gtk3=]
+ dev-libs/glib:2
+ dev-libs/libxml2:2
+ autoclose? ( ${GTK_COMMON_DEPEND} )
+ commander? ( ${GTK_COMMON_DEPEND} )
+ ctags? ( dev-util/ctags )
+ debugger? ( x11-libs/vte:0 )
+ defineformat? ( ${GTK_COMMON_DEPEND} )
+ enchant? ( app-text/enchant )
+ git? ( dev-libs/libgit2:= )
+ gpg? ( app-crypt/gpgme:1= )
+ gtkspell? (
+ gtk3? ( app-text/gtkspell:3= )
+ !gtk3? ( app-text/gtkspell:2 )
+ )
+ lua? ( dev-lang/lua:0= )
+ multiterm? (
+ $(vala_depend)
+ x11-libs/gtk+:2
+ >=x11-libs/vte-0.28:0
+ )
+ python? (
+ dev-python/pygtk[${PYTHON_USEDEP}]
+ ${PYTHON_DEPS}
+ )
+ scope? ( x11-libs/vte:0 )
+ soup? ( net-libs/libsoup:2.4 )
+"
+RDEPEND="${COMMON_DEPEND}
+ scope? ( sys-devel/gdb )
+"
+DEPEND="${COMMON_DEPEND}
+ nls? ( sys-devel/gettext )
+ virtual/pkgconfig
+"
+
+pkg_setup() {
+ use python && python-single-r1_pkg_setup
+}
+
+src_prepare() {
+ # bundled lib buster
+ rm markdown/peg-markdown/markdown_lib.c || die
+ # devhelp plugin bundles devhelp
+
+ default
+
+ use multiterm && vala_src_prepare
+}
+
+src_configure() {
+ local myeconfargs=(
+ --disable-cppcheck
+ --disable-extra-c-warnings
+ $(use_enable !gtk3 geanydoc)
+ # GeanyGenDoc requires ctpl which isn’t yet in portage
+ --disable-geanygendoc
+ # peg-markdown is bundled, use app-text/discount instead
+ --disable-peg-markdown
+ --enable-addons
+ --enable-codenav
+ --enable-geanyextrasel
+ --enable-geanyinsertnum
+ --enable-geanylatex
+ --enable-geanymacro
+ --enable-geanynumberedbookmarks
+ --enable-geanyprj
+ --enable-geanyvc
+ --enable-lineoperations
+ --enable-lipsum
+ --enable-pairtaghighlighter
+ --enable-pohelper
+ --enable-pretty-printer
+ --enable-projectorganizer
+ --enable-sendmail
+ --enable-shiftcolumn
+ --enable-tableconvert
+ --enable-treebrowser
+ --enable-xmlsnippets
+ $(use_enable autoclose)
+ $(use_enable automark)
+ $(use_enable commander)
+ $(use_enable ctags geanyctags)
+ $(use_enable debugger)
+ $(use_enable defineformat)
+ $(use_enable enchant spellcheck)
+ $(use_enable git gitchangebar)
+ $(use_enable gpg geanypg)
+ $(use_enable gtkspell)
+ $(use_enable multiterm)
+ $(use_enable lua geanylua)
+ $(use_enable nls)
+ $(use_enable overview)
+ $(use_enable python geanypy)
+ $(use_enable scope)
+ # Having updatechecker… when you’re using a package manager?
+ $(use_enable soup updatechecker)
+ $(use_enable soup geniuspaste)
+ # Relies on obsolete and vulnerable webkit-gtk versions
+ --disable-devhelp
+ --disable-markdown
+ --disable-webhelper
+ )
+
+ econf "${myeconfargs[@]}"
+}
+
+src_install() {
+ default
+
+ prune_libtool_files --modules
+
+ # make installs all translations if LINGUAS is empty
+ if [[ -n "${LINGUAS+x}" && -z "$LINGUAS" ]]; then
+ rm -r "${D}/usr/share/locale/" || die
+ fi
+}
diff --git a/dev-util/geany-plugins/geany-plugins-1.32.ebuild b/dev-util/geany-plugins/geany-plugins-1.32.ebuild
new file mode 100644
index 000000000000..305048062da6
--- /dev/null
+++ b/dev-util/geany-plugins/geany-plugins-1.32.ebuild
@@ -0,0 +1,136 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python2_7 )
+
+inherit eutils python-single-r1 vala
+
+DESCRIPTION="A collection of different plugins for Geany"
+HOMEPAGE="https://plugins.geany.org"
+SRC_URI="https://plugins.geany.org/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+
+IUSE="gtk3 ctags debugger enchant git gpg gtkspell lua multiterm nls pretty-printer python scope soup"
+REQUIRED_USE="
+ gtk3? ( !debugger !multiterm !python !scope )
+ python? ( ${PYTHON_REQUIRED_USE} )
+"
+
+COMMON_DEPEND="
+ >=dev-util/geany-1.32[gtk3=]
+ dev-libs/glib:2
+ gtk3? ( x11-libs/gtk+:3 )
+ !gtk3? ( x11-libs/gtk+:2 )
+ ctags? ( dev-util/ctags )
+ debugger? ( x11-libs/vte:0 )
+ enchant? ( app-text/enchant )
+ git? ( dev-libs/libgit2:= )
+ gpg? ( app-crypt/gpgme:1= )
+ gtkspell? (
+ gtk3? ( app-text/gtkspell:3= )
+ !gtk3? ( app-text/gtkspell:2 )
+ )
+ lua? ( dev-lang/lua:0= )
+ multiterm? (
+ $(vala_depend)
+ >=x11-libs/vte-0.28:0
+ )
+ pretty-printer? ( dev-libs/libxml2:2 )
+ python? (
+ dev-python/pygtk[${PYTHON_USEDEP}]
+ ${PYTHON_DEPS}
+ )
+ scope? ( x11-libs/vte:0 )
+ soup? ( net-libs/libsoup:2.4 )
+"
+RDEPEND="${COMMON_DEPEND}
+ scope? ( sys-devel/gdb )
+"
+DEPEND="${COMMON_DEPEND}
+ nls? ( sys-devel/gettext )
+ virtual/pkgconfig
+"
+
+pkg_setup() {
+ use python && python-single-r1_pkg_setup
+}
+
+src_prepare() {
+ default
+
+ use multiterm && vala_src_prepare
+}
+
+src_configure() {
+ local myeconfargs=(
+ --disable-cppcheck
+ --disable-extra-c-warnings
+ $(use_enable nls)
+ --enable-utilslib
+ # Plugins
+ --enable-addons
+ --enable-autoclose
+ --enable-automark
+ --enable-codenav
+ --enable-commander
+ --enable-defineformat
+ --enable-geanyextrasel
+ --enable-geanyinsertnum
+ --enable-geanylatex
+ --enable-geanymacro
+ --enable-geanyminiscript
+ --enable-geanynumberedbookmarks
+ --enable-geanyprj
+ --enable-geanyvc $(use_enable gtkspell)
+ --enable-lineoperations
+ --enable-lipsum
+ --enable-keyrecord
+ --enable-overview
+ --enable-pairtaghighlighter
+ --enable-pohelper
+ --enable-projectorganizer
+ --enable-sendmail
+ --enable-shiftcolumn
+ --enable-tableconvert
+ --enable-treebrowser
+ --enable-workbench
+ --enable-xmlsnippets
+ $(use_enable debugger)
+ $(use_enable ctags geanyctags)
+ $(use_enable !gtk3 geanydoc)
+ $(use_enable lua geanylua)
+ $(use_enable gpg geanypg)
+ $(use_enable python geanypy)
+ $(use_enable soup geniuspaste)
+ $(use_enable git gitchangebar)
+ $(use_enable multiterm)
+ $(use_enable pretty-printer)
+ $(use_enable scope)
+ $(use_enable enchant spellcheck)
+ # Having updatechecker… when you’re using a package manager?
+ $(use_enable soup updatechecker)
+ # GeanyGenDoc requires ctpl which isn’t yet in portage
+ --disable-geanygendoc
+ # Require obsolete and vulnerable webkit-gtk versions
+ --disable-devhelp
+ --disable-markdown --disable-peg-markdown
+ --disable-webhelper
+ )
+
+ econf "${myeconfargs[@]}"
+}
+
+src_install() {
+ default
+
+ prune_libtool_files --modules
+
+ # make installs all translations if LINGUAS is empty
+ if [[ -n "${LINGUAS+x}" && -z "$LINGUAS" ]]; then
+ rm -r "${D}/usr/share/locale/" || die
+ fi
+}
diff --git a/dev-util/geany-plugins/geany-plugins-1.33.ebuild b/dev-util/geany-plugins/geany-plugins-1.33.ebuild
new file mode 100644
index 000000000000..4115b2f8d7be
--- /dev/null
+++ b/dev-util/geany-plugins/geany-plugins-1.33.ebuild
@@ -0,0 +1,136 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python2_7 )
+
+inherit python-single-r1 vala
+
+DESCRIPTION="A collection of different plugins for Geany"
+HOMEPAGE="https://plugins.geany.org"
+SRC_URI="https://plugins.geany.org/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+
+IUSE="gtk3 ctags debugger enchant git gpg gtkspell lua multiterm nls pretty-printer python scope soup"
+REQUIRED_USE="
+ gtk3? ( !debugger !multiterm !python !scope )
+ python? ( ${PYTHON_REQUIRED_USE} )
+"
+
+COMMON_DEPEND="
+ >=dev-util/geany-1.32[gtk3=]
+ dev-libs/glib:2
+ gtk3? ( x11-libs/gtk+:3 )
+ !gtk3? ( x11-libs/gtk+:2 )
+ ctags? ( dev-util/ctags )
+ debugger? ( x11-libs/vte:0 )
+ enchant? ( app-text/enchant )
+ git? ( dev-libs/libgit2:= )
+ gpg? ( app-crypt/gpgme:1= )
+ gtkspell? (
+ gtk3? ( app-text/gtkspell:3= )
+ !gtk3? ( app-text/gtkspell:2 )
+ )
+ lua? ( dev-lang/lua:0= )
+ multiterm? (
+ $(vala_depend)
+ >=x11-libs/vte-0.28:0
+ )
+ pretty-printer? ( dev-libs/libxml2:2 )
+ python? (
+ dev-python/pygtk[${PYTHON_USEDEP}]
+ ${PYTHON_DEPS}
+ )
+ scope? ( x11-libs/vte:0 )
+ soup? ( net-libs/libsoup:2.4 )
+"
+RDEPEND="${COMMON_DEPEND}
+ scope? ( sys-devel/gdb )
+"
+DEPEND="${COMMON_DEPEND}
+ nls? ( sys-devel/gettext )
+ virtual/pkgconfig
+"
+
+pkg_setup() {
+ use python && python-single-r1_pkg_setup
+}
+
+src_prepare() {
+ default
+
+ use multiterm && vala_src_prepare
+}
+
+src_configure() {
+ local myeconfargs=(
+ --disable-cppcheck
+ --disable-extra-c-warnings
+ $(use_enable nls)
+ --enable-utilslib
+ # Plugins
+ --enable-addons
+ --enable-autoclose
+ --enable-automark
+ --enable-codenav
+ --enable-commander
+ --enable-defineformat
+ --enable-geanyextrasel
+ --enable-geanyinsertnum
+ --enable-geanymacro
+ --enable-geanyminiscript
+ --enable-geanynumberedbookmarks
+ --enable-geanyprj
+ --enable-geanyvc $(use_enable gtkspell)
+ --enable-keyrecord
+ --enable-latex
+ --enable-lineoperations
+ --enable-lipsum
+ --enable-overview
+ --enable-pairtaghighlighter
+ --enable-pohelper
+ --enable-projectorganizer
+ --enable-sendmail
+ --enable-shiftcolumn
+ --enable-tableconvert
+ --enable-treebrowser
+ --enable-workbench
+ --enable-xmlsnippets
+ $(use_enable debugger)
+ $(use_enable ctags geanyctags)
+ $(use_enable !gtk3 geanydoc)
+ $(use_enable lua geanylua)
+ $(use_enable gpg geanypg)
+ $(use_enable python geanypy)
+ $(use_enable soup geniuspaste)
+ $(use_enable git gitchangebar)
+ $(use_enable multiterm)
+ $(use_enable pretty-printer)
+ $(use_enable scope)
+ $(use_enable enchant spellcheck)
+ # Having updatechecker… when you’re using a package manager?
+ $(use_enable soup updatechecker)
+ # GeanyGenDoc requires ctpl which isn’t yet in portage
+ --disable-geanygendoc
+ # Require obsolete and vulnerable webkit-gtk versions
+ --disable-devhelp
+ --disable-markdown --disable-peg-markdown
+ --disable-webhelper
+ )
+
+ econf "${myeconfargs[@]}"
+}
+
+src_install() {
+ default
+
+ find "${D}" -name '*.la' -delete || die
+
+ # make installs all translations if LINGUAS is empty
+ if [[ -z "${LINGUAS-x}" ]]; then
+ rm -r "${ED%/}/usr/share/locale/" || die
+ fi
+}
diff --git a/dev-util/geany-plugins/metadata.xml b/dev-util/geany-plugins/metadata.xml
new file mode 100644
index 000000000000..ba173350cebd
--- /dev/null
+++ b/dev-util/geany-plugins/metadata.xml
@@ -0,0 +1,29 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>aklhfex@gmail.com</email>
+ <name>Chris Mayo</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Gentoo Proxy Maintainers Project</name>
+ </maintainer>
+ <use>
+ <flag name="gtk3">Use GTK+3 instead of GTK+2</flag>
+ <flag name="autoclose">Enable the autoclose plugin.</flag>
+ <flag name="automark">Enable the automark plugin</flag>
+ <flag name="commander">Enable the commander plugin which provides a command panel for rapid access to any action.</flag>
+ <flag name="ctags">Enable ctags plugin</flag>
+ <flag name="debugger">Enable the debugger plugin which interfaces with <pkg>sys-devel/gdb</pkg></flag>
+ <flag name="defineformat">Enable the defineformat plugin.</flag>
+ <flag name="enchant">Enable spell checking using enchant</flag>
+ <flag name="gpg">Enable geanypg plugin which integrates GPG using <pkg>app-crypt/gpgme</pkg></flag>
+ <flag name="gtkspell">Use gtkspell for dictionary support in GeanyVC</flag>
+ <flag name="multiterm">Enable the multiterm plugin</flag>
+ <flag name="overview">Enable overview plugin</flag>
+ <flag name="pretty-printer">Enable pretty-printer plugin</flag>
+ <flag name="scope">Enable the scope plugin which is a graphical GDB front-end</flag>
+ <flag name="soup">Enable updatechecker and geniuspaste plugins which require <pkg>net-libs/libsoup</pkg></flag>
+ </use>
+</pkgmetadata>