summaryrefslogtreecommitdiff
path: root/dev-util/envman
diff options
context:
space:
mode:
Diffstat (limited to 'dev-util/envman')
-rw-r--r--dev-util/envman/Manifest3
-rw-r--r--dev-util/envman/envman-1.2.0.ebuild38
-rw-r--r--dev-util/envman/metadata.xml19
3 files changed, 60 insertions, 0 deletions
diff --git a/dev-util/envman/Manifest b/dev-util/envman/Manifest
new file mode 100644
index 000000000000..1ba33a6f12f2
--- /dev/null
+++ b/dev-util/envman/Manifest
@@ -0,0 +1,3 @@
+DIST envman-1.2.0.tar.gz 2997860 BLAKE2B e49d3b421fb1ab226de4430e90d8c684bc3a2554205c6383a140c0832134eaba338797dca44668fc2473d248940b5499395ab3a6d3359382305fd8a719772257 SHA512 5245aea8c280a6d6022e8132216891f09abee707c0ed736bfe6b4882aa23880a771dce5371b8ba5fcdd41fa951606727e7582442d897058b25985cf9dd5a9d18
+EBUILD envman-1.2.0.ebuild 873 BLAKE2B ab827ea0ff610b6d2675f925dc65b32b47472eaca4f605341a71d332ea00527fb8f8357847a7f0bdbc3314d9182ea104dd13f9c179a8b210410190cb1472ade1 SHA512 862df91f0bed24dffec1e1c0d209aed338a2ab060c41ec147a82503a81f279b787ed2524ff0cca90be47717881b491ac7a4490736a8ac4a3011289bd7480ac11
+MISC metadata.xml 942 BLAKE2B 32b021b4b9f97464d5ff81c7541a389105d75d32ac8598474007f4f27013c0b1bff37968a4ebcf9b9e41264686aef44c43da6896426392adfaf91576ca2873fa SHA512 4fd1c54eec14f80bd804140299d2f987c404f0653c6b6adfc1715ac01cbaed0555ccb8cd87fbe6a2f34b7cb90f81cf20db817866f40ea2f6c607c7268705a089
diff --git a/dev-util/envman/envman-1.2.0.ebuild b/dev-util/envman/envman-1.2.0.ebuild
new file mode 100644
index 000000000000..6713bc5a103a
--- /dev/null
+++ b/dev-util/envman/envman-1.2.0.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit golang-build
+
+EGO_ON="github.com/bitrise-io"
+EGO_PN="${EGO_ON}/${PN}"
+
+DESCRIPTION="Environment variable manager for Bitrise CLI."
+HOMEPAGE="https://www.bitrise.io/cli"
+SRC_URI="https://${EGO_PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+
+S="${WORKDIR}/src/${EGO_ON}/${PN}"
+
+src_unpack() {
+ unpack ${A}
+ mkdir -p "${WORKDIR}/src/${EGO_ON}" || die "Couldn't create project dir in GOPATH"
+ mv "${WORKDIR}/${P}" "${WORKDIR}/src/${EGO_ON}/envman" || die "Couldn't move sources to GOPATH"
+}
+
+src_compile() {
+ GOPATH="${WORKDIR}" go build -v -o bin/envman || die "Couldn't compile envman"
+}
+
+src_test() {
+ GOPATH="${WORKDIR}" go test ./... || die "Tests failed"
+}
+
+src_install() {
+ dobin bin/envman
+ dodoc README.md
+}
diff --git a/dev-util/envman/metadata.xml b/dev-util/envman/metadata.xml
new file mode 100644
index 000000000000..c93a133753ba
--- /dev/null
+++ b/dev-util/envman/metadata.xml
@@ -0,0 +1,19 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>karol.wrotniak@droidsonroids.pl</email>
+ <name>Karol Wrótniak</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+ <longdescription>Environment variable manager for Bitrise CLI. Part of the Bitrise Continuous Integration, Delivery and Automations Stack, with stepman and bitrise. For a nice &amp; quick intro you should check: https://www.bitrise.io/cli</longdescription>
+ <upstream>
+ <bugs-to>https://github.com/bitrise-io/envman/issues</bugs-to>
+ <changelog>https://github.com/bitrise-io/envman/blob/master/CHANGELOG.md</changelog>
+ <doc>https://github.com/bitrise-io/envman/blob/master/README.md</doc>
+ <remote-id type="github">bitriseio/envman</remote-id>
+ </upstream>
+</pkgmetadata>