summaryrefslogtreecommitdiff
path: root/dev-util/ebuildtester/ebuildtester-42-r3.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-util/ebuildtester/ebuildtester-42-r3.ebuild')
-rw-r--r--dev-util/ebuildtester/ebuildtester-42-r3.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/dev-util/ebuildtester/ebuildtester-42-r3.ebuild b/dev-util/ebuildtester/ebuildtester-42-r3.ebuild
new file mode 100644
index 000000000000..f15cf5a0fb54
--- /dev/null
+++ b/dev-util/ebuildtester/ebuildtester-42-r3.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit bash-completion-r1 distutils-r1 pypi
+
+DESCRIPTION="A dockerized approach to test a Gentoo package within a clean stage3 container"
+HOMEPAGE="https://ebuildtester.readthedocs.io/"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="
+ app-containers/docker
+ app-containers/docker-cli
+ sys-fs/fuse
+"
+
+BDEPEND="
+ dev-python/setuptools-scm[${PYTHON_USEDEP}]
+"
+
+distutils_enable_sphinx docs dev-python/sphinx-rtd-theme
+distutils_enable_tests unittest
+
+src_install() {
+ distutils-r1_src_install
+ newbashcomp "${PN}.bash-completion" "${PN}"
+}