summaryrefslogtreecommitdiff
path: root/dev-util/cucumber-html-formatter/cucumber-html-formatter-21.2.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-util/cucumber-html-formatter/cucumber-html-formatter-21.2.0.ebuild')
-rw-r--r--dev-util/cucumber-html-formatter/cucumber-html-formatter-21.2.0.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/dev-util/cucumber-html-formatter/cucumber-html-formatter-21.2.0.ebuild b/dev-util/cucumber-html-formatter/cucumber-html-formatter-21.2.0.ebuild
new file mode 100644
index 000000000000..3d108c72cb09
--- /dev/null
+++ b/dev-util/cucumber-html-formatter/cucumber-html-formatter-21.2.0.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+USE_RUBY="ruby31 ruby32 ruby33"
+
+RUBY_FAKEGEM_EXTRAINSTALL="assets"
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+
+inherit ruby-fakegem
+
+DESCRIPTION="HTML formatter for Cucumber"
+HOMEPAGE="https://cucumber.io/"
+
+# Can be used for specs but requires assets to be created from npm
+#SRC_URI="https://github.com/cucumber/html-formatter/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
+#RUBY_S="html-formatter-${PV}/ruby"
+
+LICENSE="MIT"
+
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~loong ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+SLOT="$(ver_cut 1)"
+IUSE="test"
+
+# Specs are no longer available in the distributed gem
+RESTRICT="test"
+
+ruby_add_rdepend "
+ dev-util/cucumber-messages:22
+ !<dev-util/cucumber-html-formatter-20.4.0-r1:20
+"