summaryrefslogtreecommitdiff
path: root/dev-util/ctags
diff options
context:
space:
mode:
Diffstat (limited to 'dev-util/ctags')
-rw-r--r--dev-util/ctags/Manifest4
-rw-r--r--dev-util/ctags/ctags-20230423.0.ebuild10
-rw-r--r--dev-util/ctags/ctags-99999999.ebuild10
3 files changed, 18 insertions, 6 deletions
diff --git a/dev-util/ctags/Manifest b/dev-util/ctags/Manifest
index 9cd45c0258ca..402e6226becb 100644
--- a/dev-util/ctags/Manifest
+++ b/dev-util/ctags/Manifest
@@ -3,6 +3,6 @@ DIST ctags-20220828.0.tar.gz 2952276 BLAKE2B 2ec3a01646cfb89446604af65387bb5cbf1
DIST ctags-20230423.0.tar.gz 3038197 BLAKE2B 4b6114526e9dc94c95dcf1b27136fe1fde185aadcd3f880459314b6567f4ec935da10f87aaad590f4c16999adea8b15b3a153f4e80b3b9e57d9a04ecee377a09 SHA512 7a4b3ffcc4906765dda381ad637981f5ce8c6fc24d4141b8b0e9997b71767dda307dab4d2c2aa0e5ba003774c100d8f85e494e368cedbef12c8f415a13b85554
EBUILD ctags-20211017.0.ebuild 1925 BLAKE2B cb0a590ebb35343a285c808da2a0c6e917dce94aea867e5a936c9123c6f482181089545702b7c199053fac2c1c051d88edad86b494f64634563da894ba57a03c SHA512 2d0ea70c31becb2b9d4bdbc0d1877434d663c9ee8e04dea7f92693f8804a30219d18aedaecc42cadf591dc314a19e4227494a8f4090d9afd025135b0b059e08b
EBUILD ctags-20220828.0-r1.ebuild 2241 BLAKE2B 29fbb42b31926b04de114727902259df35f2490421b918d69ffa258d177a0f34532271d79ff117ab73a119a7e402954b8e0f206510f5fc014272df4b243fb672 SHA512 2e520b0a5b1f289142a2eb5335df3828beb13b529a6be37f7df2d77b564ce5ae4b215ff396623e00e34580792a51ddd928aa4fe915ae55420e388a8c10fbb146
-EBUILD ctags-20230423.0.ebuild 2238 BLAKE2B b5615a6bc1a79ad1152a8b4f19f1a776c2f3a1c8b59b9e92b19a911211af979a7f37b495c0deffe915ac071438e6608d7a1e94d2e0dfe31351ca466410cf56e1 SHA512 26b57cf14dc68d72f5fe01c23384c9e180320c6bdbb1d91a9e6adf016a1d4991fdfc2e3763121f778614eb15add0249eb49dad1cd5b1a36248850fece5a7012f
-EBUILD ctags-99999999.ebuild 2241 BLAKE2B c52bef9fcb791512567547889210657ee80830f3d49bc720e31204d6bc4c34e654388beb0995cec66ebc2cf9216c36f4fd88026416bc4ad7f7ee7532042ecd75 SHA512 1f41f4252322d63b83ab16cbfac2725232daaff3a8aca86e0db1003c97e0c54679b7adf30ebd11f06fd11ff3d6e76bc7c06668f8ecebda5c0be44bc14323bbb3
+EBUILD ctags-20230423.0.ebuild 2434 BLAKE2B 60b567b1198818605b0aeda126e2d01bbe082a86c1e86f03a0df581258c6e69e02799d395b06799e755ed820f11fdd0271256e29b571c8ba9cf6f2bf0ac19afb SHA512 e57d07f26d67e7356970b6e867e95daa36cb761c61b7d9fc7644bccd88c61792f4eb82f04ef50afd029a702a3d80f0c4d733c4d6e1892018e1043dd17f6b35bd
+EBUILD ctags-99999999.ebuild 2437 BLAKE2B 87e28bc639470848f68db4ebdb0d95f9a3b628a455caedbd587de6d778b3e28d60719f5aa17c1867cdc5521669e467119758d9ce5c883e0571be08d11e8fc33b SHA512 3dd524c3f097f1e8285f7746a003ec7ae3c4f7e61e4516c968fe7ec65ba125a0fdd3ba61cfc5d20b90db23670bebc9e070ab7151db197c20a60d98c8d27b310d
MISC metadata.xml 584 BLAKE2B 13de5ebe8bea2b413552eb85af3d3a42c453ad8d7f808b21a5b016bbd3e7890ceabdb924e817c4d841ed2862b7f9dcecad03f7f22c7b738db1c4f88d784fc80d SHA512 c4930de987c3d846c4761d66a191ae2b2800b32234f63ebafee140920faa408cec1b22032c72da01ade807a4187f482bedad3e22058fdffc0af56aabd1deea8f
diff --git a/dev-util/ctags/ctags-20230423.0.ebuild b/dev-util/ctags/ctags-20230423.0.ebuild
index 8495c309d37d..6d93df3af2aa 100644
--- a/dev-util/ctags/ctags-20230423.0.ebuild
+++ b/dev-util/ctags/ctags-20230423.0.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
-PYTHON_COMPAT=( python3_{9..11} )
+PYTHON_COMPAT=( python3_{10..13} )
inherit autotools python-any-r1
DESCRIPTION="Exuberant Ctags creates tags files for code browsing in editors"
@@ -39,6 +39,12 @@ BDEPEND="
"
IDEPEND="app-eselect/eselect-ctags"
+QA_CONFIG_IMPL_DECL_SKIP=(
+ # manual check for function in a library that doesn't exist, passes -liconv
+ # which either fails to link anyway (glibc) or passes this check (musl)
+ libiconv_open
+)
+
pkg_setup() {
use test && python-any-r1_pkg_setup
}
diff --git a/dev-util/ctags/ctags-99999999.ebuild b/dev-util/ctags/ctags-99999999.ebuild
index 7eff8886e369..2780d6573854 100644
--- a/dev-util/ctags/ctags-99999999.ebuild
+++ b/dev-util/ctags/ctags-99999999.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
-PYTHON_COMPAT=( python3_{9..11} )
+PYTHON_COMPAT=( python3_{10..13} )
inherit autotools python-any-r1
DESCRIPTION="Exuberant Ctags creates tags files for code browsing in editors"
@@ -39,6 +39,12 @@ BDEPEND="
"
IDEPEND="app-eselect/eselect-ctags"
+QA_CONFIG_IMPL_DECL_SKIP=(
+ # manual check for function in a library that doesn't exist, passes -liconv
+ # which either fails to link anyway (glibc) or passes this check (musl)
+ libiconv_open
+)
+
pkg_setup() {
use test && python-any-r1_pkg_setup
}