summaryrefslogtreecommitdiff
path: root/dev-util/crash/crash-9999.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-util/crash/crash-9999.ebuild')
-rw-r--r--dev-util/crash/crash-9999.ebuild11
1 files changed, 9 insertions, 2 deletions
diff --git a/dev-util/crash/crash-9999.ebuild b/dev-util/crash/crash-9999.ebuild
index e5ef7a7ea356..34c8d94dfb93 100644
--- a/dev-util/crash/crash-9999.ebuild
+++ b/dev-util/crash/crash-9999.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
-inherit toolchain-funcs
+inherit flag-o-matic toolchain-funcs
GDB_VERSION=10.2
if [[ ${PV} == "9999" ]] ; then
@@ -33,6 +33,13 @@ src_prepare() {
ln -s "${DISTDIR}"/gdb-10.2.tar.gz . || die
}
+src_configure() {
+ # bug #858344
+ filter-lto
+
+ default
+}
+
src_compile() {
emake \
CC="$(tc-getCC)" \