summaryrefslogtreecommitdiff
path: root/dev-util/cram/cram-0.7-r2.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-util/cram/cram-0.7-r2.ebuild')
-rw-r--r--dev-util/cram/cram-0.7-r2.ebuild11
1 files changed, 5 insertions, 6 deletions
diff --git a/dev-util/cram/cram-0.7-r2.ebuild b/dev-util/cram/cram-0.7-r2.ebuild
index 56867074f7fe..ccc328eaf126 100644
--- a/dev-util/cram/cram-0.7-r2.ebuild
+++ b/dev-util/cram/cram-0.7-r2.ebuild
@@ -1,10 +1,10 @@
# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
-PYTHON_COMPAT=( python3_{8..10} pypy3 )
-DISTUTILS_USE_SETUPTOOLS=no
+PYTHON_COMPAT=( python3_{8..11} pypy3 )
+DISTUTILS_USE_PEP517=setuptools
inherit distutils-r1
@@ -14,9 +14,8 @@ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~mips ~ppc ~ppc64 ~riscv ~x86"
+KEYWORDS="amd64 ~arm ~arm64 ~hppa ~mips ~ppc ~ppc64 ~riscv x86"
python_test() {
- distutils_install_for_testing
- "${EPYTHON}" "${TEST_DIR}"/scripts/cram tests || die "Tests fail with ${EPYTHON}"
+ "${EPYTHON}" scripts/cram tests || die "Tests fail with ${EPYTHON}"
}