summaryrefslogtreecommitdiff
path: root/dev-util/confix-wrapper
diff options
context:
space:
mode:
Diffstat (limited to 'dev-util/confix-wrapper')
-rw-r--r--dev-util/confix-wrapper/Manifest2
-rw-r--r--dev-util/confix-wrapper/confix-wrapper-1.ebuild (renamed from dev-util/confix-wrapper/confix-wrapper-0.ebuild)16
2 files changed, 10 insertions, 8 deletions
diff --git a/dev-util/confix-wrapper/Manifest b/dev-util/confix-wrapper/Manifest
index 722f07de2498..fd50882b4506 100644
--- a/dev-util/confix-wrapper/Manifest
+++ b/dev-util/confix-wrapper/Manifest
@@ -1,2 +1,2 @@
-EBUILD confix-wrapper-0.ebuild 802 BLAKE2B cf911988108d5950257959be2aa8d787d139cdc655c62a331e150717d304a692291255fdeb0d156e2194180dccabf7778e12ba03f36d117693d60f3be8fccbdb SHA512 91329de488250579866b2e928ae0dbf145b539e3f17d7da1df1cee1e5604d1e3033b95d21bc3573ab47614b9544265c68a1e0b30867f127050258d4bb554adac
+EBUILD confix-wrapper-1.ebuild 681 BLAKE2B 80a47a9b0a83c64a4e63cd6284efc8a073545df1b0dd9ca1d5147189e7fdc49931881b9d151890de74504020344cb3824b40560390a8c75cf9b2f884c3107935 SHA512 c46355ac91b3908a20544f0310f9af2675a91080d0f3d153c5642198f36c69f22d85450a240c8e65f7f38277255677558b722bee94cd63cd33fd4969bffd3bb7
MISC metadata.xml 329 BLAKE2B ce9d264f3d40c4c4a7078cfed1f27f93c06420904a98051031a91bc600c33708c10291128b48be7065eb493866d4a15d9140b5933954eba9716a7dde376e001a SHA512 a2e7c1b3ef9b2228e2820c0aa46354d771b518e7a5f854f1f06850840929846b12125b4f526a7f0282b3e9545c5cf7ed670ef2f2047c7deb0c6de40b9667b321
diff --git a/dev-util/confix-wrapper/confix-wrapper-0.ebuild b/dev-util/confix-wrapper/confix-wrapper-1.ebuild
index e8f8dcb4d2cb..685b1b97161d 100644
--- a/dev-util/confix-wrapper/confix-wrapper-0.ebuild
+++ b/dev-util/confix-wrapper/confix-wrapper-1.ebuild
@@ -1,7 +1,7 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=0
+EAPI=7
DESCRIPTION="Wrapper to select either confix1.py or confix2.py"
HOMEPAGE="http://confix.sourceforge.net"
@@ -10,10 +10,10 @@ LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~x86 ~ppc-aix ~x64-cygwin ~amd64-linux ~x86-linux ~sparc-solaris ~x86-solaris"
IUSE=""
+S=${WORKDIR}
-src_install() {
- dodir /usr/bin
- cat >> "${ED:-${D}}"usr/bin/confix <<EOF
+src_unpack() {
+ cat >> confix <<EOF || die
#! ${EPREFIX:-}/bin/sh
confixpy=
if [ -f ./Confix2.dir ]; then
@@ -28,6 +28,8 @@ case \$# in
*) exec \${confixpy} "\$@" ;;
esac
EOF
- fperms a+x /usr/bin/confix || die "cannot set permissions"
- dosym confix /usr/bin/confix.py || die "cannot create 'confix' symlink"
+}
+
+src_install() {
+ dobin confix
}