summaryrefslogtreecommitdiff
path: root/dev-util/confix-wrapper/confix-wrapper-1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-util/confix-wrapper/confix-wrapper-1.ebuild')
-rw-r--r--dev-util/confix-wrapper/confix-wrapper-1.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/dev-util/confix-wrapper/confix-wrapper-1.ebuild b/dev-util/confix-wrapper/confix-wrapper-1.ebuild
new file mode 100644
index 000000000000..685b1b97161d
--- /dev/null
+++ b/dev-util/confix-wrapper/confix-wrapper-1.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="Wrapper to select either confix1.py or confix2.py"
+HOMEPAGE="http://confix.sourceforge.net"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~ppc-aix ~x64-cygwin ~amd64-linux ~x86-linux ~sparc-solaris ~x86-solaris"
+IUSE=""
+S=${WORKDIR}
+
+src_unpack() {
+ cat >> confix <<EOF || die
+#! ${EPREFIX:-}/bin/sh
+confixpy=
+if [ -f ./Confix2.dir ]; then
+ confixpy=confix2.py
+elif [ -f ./Makefile.py ]; then
+ confixpy=confix1.py
+else
+ confixpy=confix2.py
+fi
+case \$# in
+0) exec \${confixpy} ;;
+*) exec \${confixpy} "\$@" ;;
+esac
+EOF
+}
+
+src_install() {
+ dobin confix
+}