summaryrefslogtreecommitdiff
path: root/dev-util/colm/colm-0.14.7-r1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-util/colm/colm-0.14.7-r1.ebuild')
-rw-r--r--dev-util/colm/colm-0.14.7-r1.ebuild55
1 files changed, 55 insertions, 0 deletions
diff --git a/dev-util/colm/colm-0.14.7-r1.ebuild b/dev-util/colm/colm-0.14.7-r1.ebuild
new file mode 100644
index 000000000000..831d5bc521f1
--- /dev/null
+++ b/dev-util/colm/colm-0.14.7-r1.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools
+
+DESCRIPTION="COmputer Language Manipulation"
+HOMEPAGE="https://www.colm.net/open-source/colm/"
+SRC_URI="https://www.colm.net/files/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+IUSE="doc"
+
+BDEPEND="
+ doc? (
+ || ( app-text/asciidoc dev-ruby/asciidoctor )
+ dev-python/pygments
+ )
+"
+# libfsm moved from ragel -> colm, bug #766108
+RDEPEND="!<dev-util/ragel-7.0.3"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-0.14.7-drop-julia-check.patch
+ "${FILESDIR}"/${PN}-0.14.7-disable-static-lib.patch
+)
+
+src_prepare() {
+ default
+
+ # bug #733426
+ sed -i -e 's/(\[ASCIIDOC\], \[asciidoc\], \[asciidoc\]/S([ASCIIDOC], [asciidoc asciidoctor]/' configure.ac || die
+
+ # bug #766069
+ sed -i -e "s:gcc:$(tc-getCC):" test/colm.d/gentests.sh || die
+ sed -i -e "s:g++:$(tc-getCXX):" test/colm.d/gentests.sh || die
+
+ eautoreconf
+}
+
+src_configure() {
+ econf $(use_enable doc manual)
+}
+
+src_test() {
+ # Build tests
+ default
+
+ # Run them
+ cd test || die
+ ./runtests || die
+}