summaryrefslogtreecommitdiff
path: root/dev-util/codeblocks/codeblocks-9999.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-util/codeblocks/codeblocks-9999.ebuild')
-rw-r--r--dev-util/codeblocks/codeblocks-9999.ebuild60
1 files changed, 0 insertions, 60 deletions
diff --git a/dev-util/codeblocks/codeblocks-9999.ebuild b/dev-util/codeblocks/codeblocks-9999.ebuild
deleted file mode 100644
index 9296cc13443b..000000000000
--- a/dev-util/codeblocks/codeblocks-9999.ebuild
+++ /dev/null
@@ -1,60 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI="5"
-WX_GTK_VER="3.0"
-
-inherit autotools eutils subversion wxwidgets
-
-DESCRIPTION="The open source, cross platform, free C++ IDE"
-HOMEPAGE="http://www.codeblocks.org/"
-LICENSE="GPL-3"
-SLOT="0"
-KEYWORDS=""
-SRC_URI=""
-ESVN_REPO_URI="svn://svn.code.sf.net/p/${PN}/code/trunk"
-
-IUSE="contrib debug pch static-libs"
-
-RDEPEND="app-arch/zip
- x11-libs/wxGTK:${WX_GTK_VER}[X]
- contrib? (
- app-text/hunspell
- dev-libs/boost:=
- dev-libs/libgamin
- )"
-DEPEND="${RDEPEND}
- virtual/pkgconfig"
-
-src_unpack() {
- subversion_src_unpack
-}
-
-src_prepare() {
- # Let's make the autorevision work.
- subversion_wc_info
- CB_LCD=$(LC_ALL=C svn info "${ESVN_WC_PATH}" | grep "^Last Changed Date:" | cut -d" " -f4,5)
- echo "m4_define([SVN_REV], ${ESVN_WC_REVISION})" > revision.m4
- echo "m4_define([SVN_DATE], ${CB_LCD})" >> revision.m4
- eautoreconf
-}
-
-src_configure() {
- need-wxwidgets unicode
- econf \
- --with-wx-config="${WX_CONFIG}" \
- $(use_enable debug) \
- $(use_enable pch) \
- $(use_enable static-libs static) \
- $(use_with contrib contrib-plugins all)
-}
-
-src_compile() {
- emake clean-zipfiles
- emake
-}
-
-src_install() {
- default
- prune_libtool_files
-}