summaryrefslogtreecommitdiff
path: root/dev-util/codeblocks/codeblocks-16.01.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-util/codeblocks/codeblocks-16.01.ebuild')
-rw-r--r--dev-util/codeblocks/codeblocks-16.01.ebuild45
1 files changed, 0 insertions, 45 deletions
diff --git a/dev-util/codeblocks/codeblocks-16.01.ebuild b/dev-util/codeblocks/codeblocks-16.01.ebuild
deleted file mode 100644
index 07a042e6263e..000000000000
--- a/dev-util/codeblocks/codeblocks-16.01.ebuild
+++ /dev/null
@@ -1,45 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-WX_GTK_VER="2.8"
-
-inherit eutils flag-o-matic wxwidgets
-
-DESCRIPTION="The open source, cross platform, free C++ IDE"
-HOMEPAGE="http://www.codeblocks.org/"
-LICENSE="GPL-3"
-SLOT="0"
-KEYWORDS="~amd64 ~arm ~ppc ~x86 ~x86-fbsd"
-SRC_URI="mirror://sourceforge/codeblocks/${P/-/_}.tar.gz"
-
-IUSE="contrib debug pch static-libs"
-
-S="${WORKDIR}/${P}.release"
-
-RDEPEND="app-arch/zip
- x11-libs/wxGTK:${WX_GTK_VER}[X]
- contrib? (
- app-text/hunspell
- dev-libs/boost:=
- dev-libs/libgamin
- )"
-DEPEND="${RDEPEND}
- virtual/pkgconfig"
-
-PATCHES=( "${FILESDIR}"/${P}-gcc7.patch )
-
-src_configure() {
- touch "${S}"/revision.m4 -r "${S}"/acinclude.m4
- setup-wxwidgets
-
- append-cxxflags $(test-flags-CXX -fno-delete-null-pointer-checks)
-
- econf \
- --with-wx-config="${WX_CONFIG}" \
- $(use_enable debug) \
- $(use_enable pch) \
- $(use_enable static-libs static) \
- $(use_with contrib contrib-plugins all)
-}