summaryrefslogtreecommitdiff
path: root/dev-util/coccigrep
diff options
context:
space:
mode:
Diffstat (limited to 'dev-util/coccigrep')
-rw-r--r--dev-util/coccigrep/Manifest4
-rw-r--r--dev-util/coccigrep/coccigrep-1.20.ebuild63
-rw-r--r--dev-util/coccigrep/files/50coccigrep-gentoo.el4
-rw-r--r--dev-util/coccigrep/metadata.xml11
4 files changed, 82 insertions, 0 deletions
diff --git a/dev-util/coccigrep/Manifest b/dev-util/coccigrep/Manifest
new file mode 100644
index 000000000000..8652b0ee731b
--- /dev/null
+++ b/dev-util/coccigrep/Manifest
@@ -0,0 +1,4 @@
+AUX 50coccigrep-gentoo.el 99 BLAKE2B 596f01a6ac85deca70bdcf4f50c2475c7a38e44926d719e0da5eb23a8c713f89ebad0182cdca66b3011029bcda14d0cde76d4a186a126e05b74a0ccaa8e9efd1 SHA512 13cf90c99017cfb865c1d41e9813bb20993b4a91419e4bcca6b5536e8c35bfb871616c5174dd08eb8f1726f05296205428d14eaf9e9fabcf08bff01b287581f4
+DIST coccigrep-1.20.tar.gz 33027 BLAKE2B b4d38662beaa5ad6972e21e33523c9c7253f9f124067c45b21fc0234b6aa6338481a9a3a08242c3c4227ac102b75ff7070bd7d7dcec31193d84367d1d739072d SHA512 35d6a43b515c261ba025b876a72566581f892624eb9f47cde4121f16b2922ead8cd94e2c0ea6e00e4c64a3fe0cdcc4aeadc4c49900a8de8cfc0b589208ecae9c
+EBUILD coccigrep-1.20.ebuild 1340 BLAKE2B 88058781c7994470bea93e0ee848d834c18c1f3be82a37cdbd01ca42defd98a451500f78dcbf4a5489ffa997505cd7dd2c4d8f6ac14c3c80cdb1ed6b78803a01 SHA512 e923b5ff693575cab0173fd41c94064cceecc3183602cfffd5014c88f23e0b16ba13f8936985c409032e8275e161ecc4c01567c8fb2bd8c11672b7375b9f3daa
+MISC metadata.xml 312 BLAKE2B 22969d34c7ebb142abb6844c45c08f9b52c133fd608fd2905af02eb19702a0b36c2010bd6c070a158cc73d45c86f003a4f6650d8a8afe3cd170ba5028e319eea SHA512 2a6fa7da698256ae9e56de7475fc91e1477297ba601c4e417b41b37b01d9c445745d517a28abdfc9a48590854458286a1d62fabca463056213b16d8c75382c8f
diff --git a/dev-util/coccigrep/coccigrep-1.20.ebuild b/dev-util/coccigrep/coccigrep-1.20.ebuild
new file mode 100644
index 000000000000..5a30a6669a76
--- /dev/null
+++ b/dev-util/coccigrep/coccigrep-1.20.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+DISTUTILS_SINGLE_IMPL=1
+PYTHON_COMPAT=( python3_{8..11} )
+inherit distutils-r1 elisp-common optfeature
+
+DESCRIPTION="A semantic grep for the C language"
+HOMEPAGE="https://home.regit.org/software/coccigrep/"
+SRC_URI="https://github.com/regit/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc emacs"
+
+RDEPEND="
+ dev-util/coccinelle[python,${PYTHON_SINGLE_USEDEP}]
+ emacs? ( >=app-editors/emacs-23.1:* )
+"
+BDEPEND="
+ doc? ( dev-python/sphinx )
+ emacs? ( >=app-editors/emacs-23.1:* )
+"
+
+SITEFILE="50${PN}-gentoo.el"
+
+python_compile_all() {
+ use doc && emake -C doc html
+
+ if use emacs ; then
+ elisp-compile editors/*.el || die
+ fi
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( doc/_build/html/. )
+
+ distutils-r1_python_install_all
+
+ doman ${PN}.1
+
+ if use emacs ; then
+ elisp-install ${PN} editors/*.{el,elc} || die
+ elisp-site-file-install "${FILESDIR}"/${SITEFILE} || die
+ fi
+
+ insinto /usr/share/vim/vimfiles/plugin
+ doins editors/cocci-grep.vim
+}
+
+pkg_postinst() {
+ use emacs && elisp-site-regen
+
+ optfeature "Syntax highlighting (colorized output formats)" dev-python/pygments
+}
+
+pkg_postrm() {
+ use emacs && elisp-site-regen
+}
diff --git a/dev-util/coccigrep/files/50coccigrep-gentoo.el b/dev-util/coccigrep/files/50coccigrep-gentoo.el
new file mode 100644
index 000000000000..7fbc6b93e541
--- /dev/null
+++ b/dev-util/coccigrep/files/50coccigrep-gentoo.el
@@ -0,0 +1,4 @@
+;;; coccigrep site-lisp configuration
+
+(add-to-list 'load-path "@SITELISP@")
+(require 'cocci-grep)
diff --git a/dev-util/coccigrep/metadata.xml b/dev-util/coccigrep/metadata.xml
new file mode 100644
index 000000000000..69ff36f5dcae
--- /dev/null
+++ b/dev-util/coccigrep/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>ml@gentoo.org</email>
+ <name>ML</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">regit/coccigrep</remote-id>
+ </upstream>
+</pkgmetadata>