summaryrefslogtreecommitdiff
path: root/dev-util/cmdtest/cmdtest-0.16.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-util/cmdtest/cmdtest-0.16.ebuild')
-rw-r--r--dev-util/cmdtest/cmdtest-0.16.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/dev-util/cmdtest/cmdtest-0.16.ebuild b/dev-util/cmdtest/cmdtest-0.16.ebuild
new file mode 100644
index 000000000000..be5040f8f4b2
--- /dev/null
+++ b/dev-util/cmdtest/cmdtest-0.16.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1
+
+DESCRIPTION="black box tests Unix command line tools"
+HOMEPAGE="http://liw.fi/cmdtest/"
+SRC_URI="http://code.liw.fi/debian/pool/main/c/${PN}/${PN}_${PV}.orig.tar.xz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+
+DEPEND="
+ ${PYTHON_DEPS}
+ dev-python/cliapp
+ dev-python/ttystatus
+"
+
+src_compile() {
+ addwrite /proc/self/comm
+ distutils-r1_src_compile
+}