summaryrefslogtreecommitdiff
path: root/dev-util/cmake/cmake-3.19.1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-util/cmake/cmake-3.19.1.ebuild')
-rw-r--r--dev-util/cmake/cmake-3.19.1.ebuild7
1 files changed, 5 insertions, 2 deletions
diff --git a/dev-util/cmake/cmake-3.19.1.ebuild b/dev-util/cmake/cmake-3.19.1.ebuild
index 5dc94575a14f..09d448bde370 100644
--- a/dev-util/cmake/cmake-3.19.1.ebuild
+++ b/dev-util/cmake/cmake-3.19.1.ebuild
@@ -54,8 +54,7 @@ PATCHES=(
# prefix
"${FILESDIR}"/${PN}-3.16.0_rc4-darwin-bundle.patch
"${FILESDIR}"/${PN}-3.14.0_rc3-prefix-dirs.patch
- # Next patch requires new work from prefix people
- #"${FILESDIR}"/${PN}-3.1.0-darwin-isysroot.patch
+ "${FILESDIR}"/${PN}-3.19.1-darwin-gcc.patch
# handle gentoo packaging in find modules
"${FILESDIR}"/${PN}-3.17.0_rc1-FindBLAS.patch
@@ -134,6 +133,10 @@ src_prepare() {
if [[ ${CHOST} == *-darwin* ]] ; then
sed -i -e 's/__APPLE__/__DISABLED_APPLE__/' \
Source/cmGlobalXCodeGenerator.cxx || die
+ # disable isysroot usage with GCC, we've properly instructed
+ # where things are via GCC configuration and ldwrapper
+ sed -i -e '/cmake_gnu_set_sysroot_flag/d' \
+ Modules/Platform/Apple-GNU-C{,XX}.cmake || die
fi
# Add gcc libs to the default link paths