summaryrefslogtreecommitdiff
path: root/dev-util/cmake-fedora/cmake-fedora-2.9.3.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-util/cmake-fedora/cmake-fedora-2.9.3.ebuild')
-rw-r--r--dev-util/cmake-fedora/cmake-fedora-2.9.3.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/dev-util/cmake-fedora/cmake-fedora-2.9.3.ebuild b/dev-util/cmake-fedora/cmake-fedora-2.9.3.ebuild
new file mode 100644
index 000000000000..f3f7853a9493
--- /dev/null
+++ b/dev-util/cmake-fedora/cmake-fedora-2.9.3.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake
+
+DESCRIPTION="Provides cmake helper macros and targets for linux, especially fedora developers"
+HOMEPAGE="https://pagure.io/cmake-fedora"
+SRC_URI="https://pagure.io/cmake-fedora/archive/${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND=""
+RDEPEND="${DEPEND}"
+
+# fails 1 of 7
+RESTRICT="test"
+
+src_prepare() {
+ sed -i \
+ -e '/GITIGNORE/d' \
+ -e '/INSTALL.*COPYING$/,/)$/d' \
+ "${S}"/CMakeLists.txt || die
+
+ cmake_src_prepare
+}