summaryrefslogtreecommitdiff
path: root/dev-util/clazy/clazy-1.6-r1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-util/clazy/clazy-1.6-r1.ebuild')
-rw-r--r--dev-util/clazy/clazy-1.6-r1.ebuild53
1 files changed, 0 insertions, 53 deletions
diff --git a/dev-util/clazy/clazy-1.6-r1.ebuild b/dev-util/clazy/clazy-1.6-r1.ebuild
deleted file mode 100644
index 7db5c3d63669..000000000000
--- a/dev-util/clazy/clazy-1.6-r1.ebuild
+++ /dev/null
@@ -1,53 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-inherit cmake
-
-DESCRIPTION="Compiler plugin which allows clang to understand Qt semantics"
-HOMEPAGE="https://kde.org/applications/development/org.kde.clazy"
-SRC_URI="mirror://kde/stable/${PN}/${PV}/src/${P}.tar.xz"
-
-LICENSE="LGPL-2+"
-SLOT="0"
-KEYWORDS="amd64"
-IUSE=""
-
-RDEPEND="
- >=sys-devel/llvm-3.8:=
-"
-DEPEND="${RDEPEND}"
-
-DOCS=( README.md )
-
-PATCHES=(
- "${FILESDIR}/${P}-llvm-10.patch"
- "${FILESDIR}/${P}-clang-cpp.patch"
-)
-
-src_prepare() {
- cmake_src_prepare
-
- sed -e '/install(FILES README.md COPYING-LGPL2.txt checks.json DESTINATION/d' \
- -i CMakeLists.txt || die
-
- sed -e 's|${MAN_INSTALL_DIR}|share/man/man1|' \
- -i docs/man/CMakeLists.txt || die
-}
-
-src_configure() {
- # this package requires both llvm and clang of the same version.
- # clang pulls in the equivalent llvm version, but not vice versa.
- # so, we must find llvm based on the installed clang version.
- # bug #681568
- local clang_version=$(best_version "sys-devel/clang")
- export LLVM_ROOT="/usr/lib/llvm/$(ver_cut 1 ${clang_version##sys-devel/clang-})"
- cmake_src_configure
-}
-
-src_install() {
- cmake_src_install
- mv "${D}"/usr/share/doc/clazy/* "${D}"/usr/share/doc/${PF} || die
- rmdir "${D}"/usr/share/doc/clazy || die
-}