summaryrefslogtreecommitdiff
path: root/dev-util/clazy/clazy-1.5-r1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-util/clazy/clazy-1.5-r1.ebuild')
-rw-r--r--dev-util/clazy/clazy-1.5-r1.ebuild8
1 files changed, 4 insertions, 4 deletions
diff --git a/dev-util/clazy/clazy-1.5-r1.ebuild b/dev-util/clazy/clazy-1.5-r1.ebuild
index d3f38a652bb6..cc5cf804601c 100644
--- a/dev-util/clazy/clazy-1.5-r1.ebuild
+++ b/dev-util/clazy/clazy-1.5-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -11,11 +11,11 @@ SRC_URI="mirror://kde/stable/${PN}/${PV}/src/${P}.tar.xz"
LICENSE="LGPL-2+"
SLOT="0"
-KEYWORDS="~amd64"
+KEYWORDS="amd64"
IUSE=""
RDEPEND="
- sys-devel/clang:=
+ <sys-devel/clang-10:=
>=sys-devel/llvm-3.8:=
"
DEPEND="${RDEPEND}"
@@ -37,7 +37,7 @@ src_configure() {
# clang pulls in the equivalent llvm version, but not vice versa.
# so, we must find llvm based on the installed clang version.
# bug #681568
- local clang_version=$(best_version sys-devel/clang)
+ local clang_version=$(best_version "<sys-devel/clang-10")
export LLVM_ROOT="/usr/lib/llvm/$(ver_cut 1 ${clang_version##sys-devel/clang-})"
cmake_src_configure
}