summaryrefslogtreecommitdiff
path: root/dev-util/ccache/files
diff options
context:
space:
mode:
Diffstat (limited to 'dev-util/ccache/files')
-rw-r--r--dev-util/ccache/files/ccache-4.0-atomic.patch21
-rw-r--r--dev-util/ccache/files/ccache-4.0-avoid-run-user.patch18
2 files changed, 0 insertions, 39 deletions
diff --git a/dev-util/ccache/files/ccache-4.0-atomic.patch b/dev-util/ccache/files/ccache-4.0-atomic.patch
deleted file mode 100644
index 87b237c7dd56..000000000000
--- a/dev-util/ccache/files/ccache-4.0-atomic.patch
+++ /dev/null
@@ -1,21 +0,0 @@
---- a/src/CMakeLists.txt
-+++ b/src/CMakeLists.txt
-@@ -63,11 +63,17 @@ if(WIN32)
- endif()
- endif()
-
-+option(LINK_WITH_ATOMIC "Add 'atomic' if needed" OFF)
-+set(atomic_lib "")
-+if(LINK_WITH_ATOMIC)
-+ set(atomic_lib "atomic")
-+endif()
-+
- find_package(Threads REQUIRED)
- target_link_libraries(
- ccache_lib
- PRIVATE standard_settings standard_warnings ZSTD::ZSTD
-- Threads::Threads third_party_lib)
-+ Threads::Threads third_party_lib ${atomic_lib})
-
- target_include_directories(ccache_lib PRIVATE ${CMAKE_BINARY_DIR} .)
-
diff --git a/dev-util/ccache/files/ccache-4.0-avoid-run-user.patch b/dev-util/ccache/files/ccache-4.0-avoid-run-user.patch
deleted file mode 100644
index 07da25c6c341..000000000000
--- a/dev-util/ccache/files/ccache-4.0-avoid-run-user.patch
+++ /dev/null
@@ -1,18 +0,0 @@
-Gentoo's sandbox does not whitelist this path by default yet.
-TODO: bug link.
-
-Until we have a sandbox whitelisting the path let's rely on ccache's default.
---- a/src/Config.cpp
-+++ b/src/Config.cpp
-@@ -833,11 +833,5 @@ Config::check_key_tables_consistency()
- std::string
- Config::default_temporary_dir(const std::string& cache_dir)
- {
--#ifdef HAVE_GETEUID
-- std::string user_tmp_dir = fmt::format("/run/user/{}", geteuid());
-- if (Stat::stat(user_tmp_dir).is_directory()) {
-- return user_tmp_dir + "/ccache-tmp";
-- }
--#endif
- return cache_dir + "/tmp";
- }