summaryrefslogtreecommitdiff
path: root/dev-util/bpftool/bpftool-6.0.12.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-util/bpftool/bpftool-6.0.12.ebuild')
-rw-r--r--dev-util/bpftool/bpftool-6.0.12.ebuild13
1 files changed, 9 insertions, 4 deletions
diff --git a/dev-util/bpftool/bpftool-6.0.12.ebuild b/dev-util/bpftool/bpftool-6.0.12.ebuild
index 6833c60b6e2a..0ea6f12c98cd 100644
--- a/dev-util/bpftool/bpftool-6.0.12.ebuild
+++ b/dev-util/bpftool/bpftool-6.0.12.ebuild
@@ -1,4 +1,4 @@
-# Copyright 2021-2022 Gentoo Authors
+# Copyright 2021-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -41,6 +41,7 @@ DEPEND="
BDEPEND="
${LINUX_PATCH+dev-util/patchutils}
${PYTHON_DEPS}
+ app-arch/tar
dev-python/docutils
"
@@ -54,10 +55,9 @@ src_unpack() {
tools/{arch,build,include,lib,perf,scripts} {scripts,include,lib} "arch/*/lib"
)
- # We expect the tar implementation to support the -j option (both
- # GNU tar and libarchive's tar support that).
+ # We expect the tar implementation to support the -j and --wildcards option
echo ">>> Unpacking ${LINUX_SOURCES} (${paths[*]}) to ${PWD}"
- tar --wildcards -xpf "${DISTDIR}"/${LINUX_SOURCES} \
+ gtar --wildcards -xpf "${DISTDIR}"/${LINUX_SOURCES} \
"${paths[@]/#/linux-${LINUX_VER}/}" || die
if [[ -n ${LINUX_PATCH} ]] ; then
@@ -86,6 +86,11 @@ src_prepare() {
popd || die
fi
+ pushd "${S_K}" >/dev/null || die
+ # bug #890638
+ eapply "${FILESDIR}"/5.19.12-no-stack-protector.patch
+ popd || die
+
# dev-python/docutils installs rst2man.py, not rst2man
sed -i -e 's/rst2man/rst2man.py/g' Documentation/Makefile || die
}