summaryrefslogtreecommitdiff
path: root/dev-util/bnfc/bnfc-2.8.1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-util/bnfc/bnfc-2.8.1.ebuild')
-rw-r--r--dev-util/bnfc/bnfc-2.8.1.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/dev-util/bnfc/bnfc-2.8.1.ebuild b/dev-util/bnfc/bnfc-2.8.1.ebuild
new file mode 100644
index 000000000000..054b7ddd2bc9
--- /dev/null
+++ b/dev-util/bnfc/bnfc-2.8.1.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+# ebuild generated by hackport 0.4.6.9999
+
+CABAL_FEATURES="bin lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+MY_PN="BNFC"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="A compiler front-end generator"
+HOMEPAGE="http://bnfc.digitalgrammars.com/"
+SRC_URI="mirror://hackage/packages/archive/${MY_PN}/${PV}/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+RESTRICT=test # missing files
+
+RDEPEND="dev-haskell/mtl:=[profile?]
+ >=dev-lang/ghc-7.4.1:=
+"
+DEPEND="${RDEPEND}
+ dev-haskell/alex
+ >=dev-haskell/cabal-1.8
+ dev-haskell/happy
+ test? ( >=dev-haskell/doctest-0.8
+ dev-haskell/hspec
+ dev-haskell/hunit
+ >=dev-haskell/quickcheck-2.5
+ dev-haskell/temporary )
+"
+
+S="${WORKDIR}/${MY_P}"