summaryrefslogtreecommitdiff
path: root/dev-util/bless/bless-0.6.0-r4.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'dev-util/bless/bless-0.6.0-r4.ebuild')
-rw-r--r--dev-util/bless/bless-0.6.0-r4.ebuild52
1 files changed, 0 insertions, 52 deletions
diff --git a/dev-util/bless/bless-0.6.0-r4.ebuild b/dev-util/bless/bless-0.6.0-r4.ebuild
deleted file mode 100644
index e7ae88c0e92e..000000000000
--- a/dev-util/bless/bless-0.6.0-r4.ebuild
+++ /dev/null
@@ -1,52 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-inherit autotools gnome2 mono-env
-
-DESCRIPTION="GTK# Hex Editor"
-HOMEPAGE="https://github.com/bwrsandman/Bless/"
-SRC_URI="https://dev.gentoo.org/~ikelos/devoverlay-distfiles/${P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="debug"
-
-RDEPEND="
- >=dev-lang/mono-1.1.14
- >=dev-dotnet/gtk-sharp-2.12.21:2
-"
-DEPEND="${RDEPEND}
- app-text/rarian
- >=sys-devel/gettext-0.15
- virtual/pkgconfig
-"
-
-# See bug 278162
-# Waiting on nunit ebuild entering the tree
-RESTRICT="test"
-
-pkg_setup() {
- # Stolen from enlightenment.eclass
- cp $(type -p gettextize) "${T}/" || die "Could not copy gettextize"
- sed -i -e 's:read dummy < /dev/tty::' "${T}/gettextize"
-
- mono-env_pkg_setup
-}
-
-src_prepare() {
- einfo "Running gettextize -f --no-changelog..."
- ( "${T}/gettextize" -f --no-changelog > /dev/null ) || die "gettexize failed"
- eapply "${FILESDIR}/${P}-pixmap.patch"
- eapply "${FILESDIR}/${P}-docpath.patch"
- eapply "${FILESDIR}/${P}-mono-4.patch"
- eautoreconf
- gnome2_src_prepare
-}
-
-src_configure() {
- gnome2_src_configure \
- --enable-unix-specific \
- $(use_enable debug)
-}