summaryrefslogtreecommitdiff
path: root/dev-util/bear/files
diff options
context:
space:
mode:
Diffstat (limited to 'dev-util/bear/files')
-rw-r--r--dev-util/bear/files/bear-3.0.21-clang16-tests.patch32
-rw-r--r--dev-util/bear/files/bear-3.0.21-libfmt-10.0.0.patch26
-rw-r--r--dev-util/bear/files/bear-3.1.4-reduce-grpc-verbosity.patch41
-rw-r--r--dev-util/bear/files/bear-3.1.4-tests.patch49
4 files changed, 90 insertions, 58 deletions
diff --git a/dev-util/bear/files/bear-3.0.21-clang16-tests.patch b/dev-util/bear/files/bear-3.0.21-clang16-tests.patch
deleted file mode 100644
index 19c63ba60849..000000000000
--- a/dev-util/bear/files/bear-3.0.21-clang16-tests.patch
+++ /dev/null
@@ -1,32 +0,0 @@
-https://github.com/rizsotto/Bear/pull/521
-
-From 472cbed312444cdcef9102e924c79070ea1d3ab2 Mon Sep 17 00:00:00 2001
-From: Florian Weimer <fweimer@redhat.com>
-Date: Sat, 15 Apr 2023 19:37:41 +0200
-Subject: [PATCH] Avoid implicit function declarations in tests, for C99
- compatibility
-
-Include <stdio.h> for printf and define _GNU_SOURCE for execvpe.
-
-Future compilers will not support implicit function declartions by
-default, causing these tests to fail to build.
---- a/test/cases/intercept/preload/errno_reset.c
-+++ b/test/cases/intercept/preload/errno_reset.c
-@@ -5,6 +5,7 @@
- #include <stdlib.h>
- #include <errno.h>
- #include <string.h>
-+#include <stdio.h>
-
- int main()
- {
---- a/test/cases/intercept/preload/posix/execvpe/success.c
-+++ b/test/cases/intercept/preload/posix/execvpe/success.c
-@@ -8,6 +8,7 @@
- #include "config.h"
-
- #if defined HAVE_UNISTD_H
-+#define _GNU_SOURCE
- #include <unistd.h>
- #endif
-
diff --git a/dev-util/bear/files/bear-3.0.21-libfmt-10.0.0.patch b/dev-util/bear/files/bear-3.0.21-libfmt-10.0.0.patch
deleted file mode 100644
index 7c8425e46ede..000000000000
--- a/dev-util/bear/files/bear-3.0.21-libfmt-10.0.0.patch
+++ /dev/null
@@ -1,26 +0,0 @@
-BUG: https://bugs.gentoo.org/906082
-UPSTREAM: https://github.com/rizsotto/Bear/pull/526
-
-From 46a032fa0fc8131779ece13f26735ec84be891e8 Mon Sep 17 00:00:00 2001
-From: jinqiang zhang <peeweep@0x0.ee>
-Date: Thu, 11 May 2023 03:33:17 +0800
-Subject: [PATCH] dependency: fix fmt 10.0.0 incompatibilities (#526)
-
-Signed-off-by: jinqiang zhang <peeweep@0x0.ee>
----
- source/CMakeLists.txt | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
-diff --git a/source/CMakeLists.txt b/source/CMakeLists.txt
-index 6da1131f..fe6b710b 100644
---- a/source/CMakeLists.txt
-+++ b/source/CMakeLists.txt
-@@ -29,7 +29,7 @@ find_package(spdlog REQUIRED)
- find_package(PkgConfig REQUIRED)
- pkg_check_modules(gRPC REQUIRED IMPORTED_TARGET protobuf grpc++)
-
--if (fmt_VERSION_MAJOR EQUAL 9)
-+if (fmt_VERSION_MAJOR GREATER_EQUAL 9)
- set(FMT_NEEDS_OSTREAM_FORMATTER 1)
- set(HAVE_FMT_STD_H 1) # FIXME: this should be done with `check_include_file`
- endif ()
diff --git a/dev-util/bear/files/bear-3.1.4-reduce-grpc-verbosity.patch b/dev-util/bear/files/bear-3.1.4-reduce-grpc-verbosity.patch
new file mode 100644
index 000000000000..b54d1d4ccb54
--- /dev/null
+++ b/dev-util/bear/files/bear-3.1.4-reduce-grpc-verbosity.patch
@@ -0,0 +1,41 @@
+From fc09623adbf4581a50b1355c27a4df849ffb18c4 Mon Sep 17 00:00:00 2001
+From: Paul Zander <negril.nx+gentoo@gmail.com>
+Date: Tue, 6 Aug 2024 12:03:17 +0200
+Subject: [PATCH] make gRPC less verbose in tests
+
+Bug: https://github.com/grpc/grpc/issues/37222
+Signed-off-by: Paul Zander <negril.nx+gentoo@gmail.com>
+---
+ test/cases/intercept/preload/build_stderr_captured.sh | 2 +-
+ test/cases/intercept/wrapper/build_stderr_captured.sh | 2 +-
+ 2 files changed, 2 insertions(+), 2 deletions(-)
+
+diff --git a/test/cases/intercept/preload/build_stderr_captured.sh b/test/cases/intercept/preload/build_stderr_captured.sh
+index b7c7d97..47ea183 100644
+--- a/test/cases/intercept/preload/build_stderr_captured.sh
++++ b/test/cases/intercept/preload/build_stderr_captured.sh
+@@ -2,7 +2,7 @@
+
+ # REQUIRES: preload, shell, dynamic-shell
+ # RUN: %{shell} %s 2> %t.orig.stderr
+-# RUN: %{intercept} --output %t.json -- %{shell} %s 2> %t.fwd.stderr
++# RUN: env GRPC_VERBOSITY="ERROR" %{intercept} --output %t.json -- %{shell} %s 2> %t.fwd.stderr
+ # RUN: diff %t.orig.stderr %t.fwd.stderr
+
+ >&2 $ECHO "Lorem ipsum dolor sit amet, consectetur adipiscing elit,"
+diff --git a/test/cases/intercept/wrapper/build_stderr_captured.sh b/test/cases/intercept/wrapper/build_stderr_captured.sh
+index f99dbbc..4d2be8b 100644
+--- a/test/cases/intercept/wrapper/build_stderr_captured.sh
++++ b/test/cases/intercept/wrapper/build_stderr_captured.sh
+@@ -2,7 +2,7 @@
+
+ # REQUIRES: shell
+ # RUN: %{shell} %s 2> %t.orig.stderr
+-# RUN: %{intercept} --force-wrapper --output %t.json -- %{shell} %s 2> %t.fwd.stderr
++# RUN: env GRPC_VERBOSITY="ERROR" %{intercept} --force-wrapper --output %t.json -- %{shell} %s 2> %t.fwd.stderr
+ # RUN: diff %t.orig.stderr %t.fwd.stderr
+
+ >&2 $ECHO "Lorem ipsum dolor sit amet, consectetur adipiscing elit,"
+--
+2.45.2
+
diff --git a/dev-util/bear/files/bear-3.1.4-tests.patch b/dev-util/bear/files/bear-3.1.4-tests.patch
new file mode 100644
index 000000000000..d6df55908cbc
--- /dev/null
+++ b/dev-util/bear/files/bear-3.1.4-tests.patch
@@ -0,0 +1,49 @@
+From: Paul Zander <negril.nx+gentoo@gmail.com>
+Subject: [PATCH] Fix tests
+# https://github.com/rizsotto/Bear/issues/445
+diff --git a/test/lit.cfg b/test/lit.cfg
+index 2a3868a..cf0c9de 100644
+--- a/test/lit.cfg
++++ b/test/lit.cfg
+@@ -31,6 +31,7 @@ config.excludes = []
+
+ config.environment['LC_CTYPE'] = 'en_US.UTF-8'
+ config.environment['PATH'] = ":".join([os.path.join(this_dir, 'bin'), os.environ.get('PATH')])
++config.environment['PYTHONDONTWRITEBYTECODE'] = '1'
+
+ # add bear install directory in case if it's not in the path
+ if '_BEAR_BIN_DIR' in lit_config.params:
+@@ -161,6 +162,12 @@ if which('nvcc'):
+ path = which('nvcc')
+ config.substitutions.append(('%{cuda}', path))
+ config.available_features.add('cuda')
++ if 'NVCC_PREPEND_FLAGS' in os.environ:
++ config.environment['NVCC_PREPEND_FLAGS'] = os.environ.get('NVCC_PREPEND_FLAGS')
++ if 'NVCC_APPEND_FLAGS' in os.environ:
++ config.environment['NVCC_APPEND_FLAGS'] = os.environ.get('NVCC_APPEND_FLAGS')
++ if 'NVCC_CCBIN' in os.environ:
++ config.environment['NVCC_CCBIN'] = os.environ.get('NVCC_CCBIN')
+
+
+ # check if libtool command is available
+@@ -183,7 +183,7 @@ if which('fakeroot'):
+
+
+ # check if valgrind is available
+-if which('valgrind'):
++if which('valgrind') and False:
+ path = which('valgrind')
+ config.substitutions.append(('%{valgrind}', path))
+ config.available_features.add('valgrind')
+diff --git a/test/cases/compilation/output/compile_cuda.sh b/test/cases/compilation/output/compile_cuda.sh
+index 41b8b37..9ef4954 100644
+--- a/test/cases/compilation/output/compile_cuda.sh
++++ b/test/cases/compilation/output/compile_cuda.sh
+@@ -8,5 +8,5 @@
+
+ touch successful_build_1.cu successful_build_2.cu
+
+-$CC -c -o successful_build_1.o successful_build_1.cu;
+-$CC -c -o successful_build_2.o successful_build_2.cu;
++$CC${NVCC_CCBIN:+ -ccbin ${NVCC_CCBIN}}${NVCC_PREPEND_FLAGS:+ ${NVCC_PREPEND_FLAGS}} -c -o successful_build_1.o successful_build_1.cu${NVCC_APPEND_FLAGS:+ ${NVCC_APPEND_FLAGS}};
++$CC${NVCC_CCBIN:+ -ccbin ${NVCC_CCBIN}}${NVCC_PREPEND_FLAGS:+ ${NVCC_PREPEND_FLAGS}} -c -o successful_build_2.o successful_build_2.cu${NVCC_APPEND_FLAGS:+ ${NVCC_APPEND_FLAGS}};