summaryrefslogtreecommitdiff
path: root/dev-util/bazel
diff options
context:
space:
mode:
Diffstat (limited to 'dev-util/bazel')
-rw-r--r--dev-util/bazel/Manifest2
-rw-r--r--dev-util/bazel/bazel-0.13.0.ebuild78
2 files changed, 80 insertions, 0 deletions
diff --git a/dev-util/bazel/Manifest b/dev-util/bazel/Manifest
index 8544e6940b1f..145541c53dcc 100644
--- a/dev-util/bazel/Manifest
+++ b/dev-util/bazel/Manifest
@@ -1,5 +1,7 @@
DIST bazel-0.10.1-dist.zip 92973197 BLAKE2B a1d681407e2c72a57b3dcbb5e2afc49e59670be65da3d7d038dc3b8593bc0ab5b4a06c8dd8fc8a617a92eef2fc26a049b6de9a1eab0d05f31efb2fbeeb9ce711 SHA512 1894c951fd39a084011f89dd0d458e182525c2bfd6c80da071865e981e21a8c2b8363530ab53af18e6deae4a488744d6d2b7a5a4acf04715c2e26560a01df707
+DIST bazel-0.13.0-dist.zip 90105262 BLAKE2B cb065025524123babef187bac2e1f54f43645d08cb1282a5fe8f8c8b090e595570646072e2380836e2c43403f7953f97321becc24b743d7b9ab43ad208cf2c2d SHA512 3c128e551cff1b685250a68892ca3e1ad6be8b152ee2b8eb527c94adbb8fd50c70e703a363bb938916275030ddb14d756c14e4dc238e7a7b40289c700c5d53c7
DIST bazel-0.7.0-dist.zip 84669893 BLAKE2B 2f8bbe3a48224a797bdebdaad8f7c403c8b0232ada5eee8c8619f241e9670dda311b9280f48b5e2013079f959891d94f55aee2af0dfae9fc4f6a486663fa245d SHA512 039ab6a04fd4422bd14503187e6cc0d07301723b3ecae906606fa12ccea72190d82237899c103c1adfdf05dc8672887790780ddfb4cce87cd590adbde3d3f6d4
EBUILD bazel-0.10.1.ebuild 2006 BLAKE2B d504972b5370261cdd09db5fd2e7f2cc87c0fcc0d256659c73b3c2114f8db095371456f2bd7e6367b23c6f91d22326e7041516e8d439489417fd21f1b02bcf93 SHA512 695034a4ee0a490b4f68371b60ad6b1864be19adf166b6d6d9dc5cf367767101862e5d207e91f2565bf0597345d0ce9a29db8d3aa198c49b54d8557fa300b375
+EBUILD bazel-0.13.0.ebuild 2006 BLAKE2B d504972b5370261cdd09db5fd2e7f2cc87c0fcc0d256659c73b3c2114f8db095371456f2bd7e6367b23c6f91d22326e7041516e8d439489417fd21f1b02bcf93 SHA512 695034a4ee0a490b4f68371b60ad6b1864be19adf166b6d6d9dc5cf367767101862e5d207e91f2565bf0597345d0ce9a29db8d3aa198c49b54d8557fa300b375
EBUILD bazel-0.7.0.ebuild 1977 BLAKE2B 3ea58cf2048b9825a17a01853d56f1f28cd2b84e14137bb4ef52d1d895c8351723447ae15e9ac379c21b8cd658bd21030058045aede3415bfac4c2591859b4c2 SHA512 1ebbd3512a16af79b14cec5e365dd43cc280356cd9fe1bd9af10db2f81fc69ddabd337cab48a960731c9d5a9cde0d4fba8ed1cdf57356d9603b6a959edb67e76
MISC metadata.xml 703 BLAKE2B a019fea848bd86537d64d63746c1d7459ec1b511ac77c0c8ca9caee9e2b888ad99c15cdb5aca00ad6d6bbbfcfb5a2da05632af4d67b40d231e2234484f2eeb11 SHA512 46c1f55e4949ef3b7d42d769e31e34fcc9bffbe4b36cf6a467a514f8471325597d417f3da5ff955203fdc880531502969cef4fcedb4536cc7bfc64d2b7e50c5d
diff --git a/dev-util/bazel/bazel-0.13.0.ebuild b/dev-util/bazel/bazel-0.13.0.ebuild
new file mode 100644
index 000000000000..5a238c7915f2
--- /dev/null
+++ b/dev-util/bazel/bazel-0.13.0.ebuild
@@ -0,0 +1,78 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit bash-completion-r1 java-pkg-2
+
+DESCRIPTION="Fast and correct automated build system"
+HOMEPAGE="http://bazel.io/"
+SRC_URI="https://github.com/bazelbuild/bazel/releases/download/${PV}/${P}-dist.zip"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="examples tools zsh-completion"
+# strip corrupts the bazel binary
+RESTRICT="strip"
+RDEPEND="virtual/jdk:1.8"
+DEPEND="${RDEPEND}
+ app-arch/unzip
+ app-arch/zip"
+
+S="${WORKDIR}"
+
+pkg_setup() {
+ echo ${PATH} | grep -q ccache && \
+ ewarn "${PN} usually fails to compile with ccache, you have been warned"
+ java-pkg-2_pkg_setup
+}
+
+src_compile() {
+ # F: fopen_wr
+ # S: deny
+ # P: /proc/self/setgroups
+ # A: /proc/self/setgroups
+ # R: /proc/24939/setgroups
+ # C: /usr/lib/systemd/systemd
+ addpredict /proc
+ VERBOSE=yes ./compile.sh || die
+ # Use standalone strategy to deactivate the bazel sandbox, since it
+ # conflicts with FEATURES=sandbox.
+ echo "build --verbose_failures --spawn_strategy=standalone --genrule_strategy=standalone" \
+ > "${T}/bazelrc" || die
+ output/bazel --bazelrc="${T}/bazelrc" build scripts:bazel-complete.bash || die
+ mv bazel-bin/scripts/bazel-complete.bash output/ || die
+}
+
+src_test() {
+ output/bazel test \
+ --verbose_failures \
+ --spawn_strategy=standalone \
+ --genrule_strategy=standalone \
+ --verbose_test_summary \
+ examples/cpp:hello-success_test || die
+}
+
+src_install() {
+ output/bazel shutdown
+ dobin output/bazel
+ newbashcomp output/bazel-complete.bash ${PN}
+ bashcomp_alias ${PN} ibazel
+ if use zsh-completion ; then
+ insinto /usr/share/zsh/site-functions
+ doins scripts/zsh_completion/_bazel
+ fi
+ if use examples; then
+ docinto examples
+ dodoc -r examples/*
+ docompress -x /usr/share/doc/${PF}/examples
+ fi
+ # could really build tools but I don't know which ones
+ # are actually used
+ if use tools; then
+ docinto tools
+ dodoc -r tools/*
+ docompress -x /usr/share/doc/${PF}/tools
+ fi
+}